Bug 1329906 - Storage domain ownership of LUN not displayed.
Summary: Storage domain ownership of LUN not displayed.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.0.0-beta
: 4.0.0
Assignee: Fred Rolland
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On:
Blocks: 1330483
TreeView+ depends on / blocked
 
Reported: 2016-04-24 17:01 UTC by Ameya Charekar
Modified: 2019-10-10 11:58 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1330483 (view as bug list)
Environment:
Last Closed: 2016-08-23 20:38:00 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
screen shot (257.49 KB, image/png)
2016-06-05 15:49 UTC, Kevin Alon Goldblatt
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1743 0 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0 GA Enhancement (ovirt-engine) 2016-09-02 21:54:01 UTC
oVirt gerrit 56570 0 master MERGED webadmin: Enable tooltip on greyed out LUNs 2016-04-25 13:58:26 UTC

Description Ameya Charekar 2016-04-24 17:01:43 UTC
Description of problem:

When editing a fibre channel storage domain, you are presented with a list of used and available LUNs.
Those that are "used" are indicated by a small green tick to the left of the WWID.
Hovering over this area should display the storage domain ownership of that LUN.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Hover mouse pointer on already used LUNs.
2. 
3.

Actual results:
No information is displayed.

Expected results:
Should display -> LUN is already part of Storage Domain: <storage_domain_name>

Additional info:
Working in rhev 3.5 (Red Hat Bugzilla – Bug 1109721)

Comment 3 Kevin Alon Goldblatt 2016-06-05 15:23:29 UTC
Test the with the following code:
------------------------------------------
rhevm-4.0.0.2-0.1.el7ev.noarch
vdsm-4.18.1-11.gita92976e.el7ev.x86_64


Tested with the following scenario:
-------------------------------------
1. Via the Webadmin -> Storage Tab -> Double clicked the iscsi storage domain - Hovered over the Used LUN which is displayed with a green 'Check - V' icon >>>> The correct information is displayed indicating that the LUN is 'Already part of a domain xxxxx'

Moving to VERIFIED! 
Adding Screenshot with correcct display

Comment 4 Kevin Alon Goldblatt 2016-06-05 15:49:06 UTC
Created attachment 1164918 [details]
screen shot

Added screen shot of correct display in tool tip

Comment 6 errata-xmlrpc 2016-08-23 20:38:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html


Note You need to log in before you can comment on or make changes to this bug.