Bug 1329910 - journald spamming acpi logs
Summary: journald spamming acpi logs
Keywords:
Status: CLOSED DUPLICATE of bug 1328633
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1335622 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-24 19:28 UTC by Łukasz Posadowski
Modified: 2016-05-12 21:24 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-09 14:51:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Łukasz Posadowski 2016-04-24 19:28:14 UTC
Description of problem:
journald is spamming like crazy. Today during a second 20:53:14 i got 1098 messages like that:
[...]
kwi 24 20:53:14 mamut2 kernel: ACPI Error: No handler or method for GPE 01, disabling event (20160108/evgpe-790)
kwi 24 20:53:14 mamut2 systemd-journald[4982]: Missed 128 kernel messages
kwi 24 20:53:14 mamut2 kernel: ACPI Error: No handler or method for GPE 0A, disabling event (20160108/evgpe-790)
kwi 24 20:53:14 mamut2 systemd-journald[4982]: Missed 136 kernel messages
kwi 24 20:53:14 mamut2 kernel: ACPI Error: No handler or method for GPE 07, disabling event (20160108/evgpe-790)
kwi 24 20:53:14 mamut2 systemd-journald[4982]: Missed 110 kernel messages
kwi 24 20:53:14 mamut2 kernel: ACPI Error: No handler or method for GPE 06, disabling event (20160108/evgpe-790)
kwi 24 20:53:14 mamut2 systemd-journald[4982]: Missed 101 kernel messages
kwi 24 20:53:14 mamut2 kernel: ACPI Error: No handler or method for GPE 01, disabling event (20160108/evgpe-790)
[...]

Sometimes it happens during installation from the live media. System on my laptop (only dual core 900MHz with integrated Radeon) is totally unusable. Journald takes almost 100% of CPU, even "sudo rebooot" doesn't respond and hang for 5 minutes.

Version-Release number of selected component (if applicable):
Whatever is on Fedora 24 right now.

How reproducible:
Not very often and I have no idea how to provoke that behaviour.

Steps to Reproduce:
1. Run Fedora 24.
2. Wait...
3.

Actual results:
Journald is spamming thousand messages per second.

Expected results:
Journald isn't spamming thousand messages per second. I know that something is wrong, but doesn't have to be remindered every milisecond. :)


Additional info:
I'm really stuck. Please give me at least a clue to understand what is happening. I'm hoping that it can be fixed.

Thanks.

Comment 1 Ted Felix 2016-04-24 23:04:43 UTC
This is a kernel issue, not acpid.

Comment 2 Jaroslav Škarvada 2016-04-25 10:02:31 UTC
Reassigning to kernel per comment 1.

Comment 3 Łukasz Posadowski 2016-05-05 06:45:07 UTC
Looks like patch (at least for 4.6 kernel) is on the way:
https://bugzilla.kernel.org/show_bug.cgi?id=114201#c44

For now, blacklisting module sp5100_tco in /etc/default/grub seems to help.

Comment 4 Justin M. Forbes 2016-05-09 14:51:00 UTC

*** This bug has been marked as a duplicate of bug 1328633 ***

Comment 5 Luya Tshimbalanga 2016-05-12 21:24:56 UTC
*** Bug 1335622 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.