Bug 1330036 - Initial-setup : A message "Error during registration" when system is registered successfully but auto-attach failed due to installed products not being covered by a single service-level
Summary: Initial-setup : A message "Error during registration" when system is register...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-25 10:28 UTC by Shwetha Kallesh
Modified: 2018-04-10 09:48 UTC (History)
4 users (show)

Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-04-10 09:47:31 UTC


Attachments (Terms of Use)
Registration with subscription manager is done message (105.59 KB, image/png)
2016-04-25 10:28 UTC, Shwetha Kallesh
no flags Details
Error on RHSM spoke (140.77 KB, image/png)
2016-04-25 10:29 UTC, Shwetha Kallesh
no flags Details
See the message "System is successfully registered" (159.42 KB, image/png)
2017-11-10 08:23 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:48:38 UTC
Github candlepin subscription-manager pull 1669 None None None 2017-07-20 12:26:51 UTC

Description Shwetha Kallesh 2016-04-25 10:28:58 UTC
Created attachment 1150398 [details]
Registration with subscription manager is done message

Description of problem:
Initial-setup : A message "Error during registration" when system is registered successfully but auto-attach failed due to installed products not being covered by a single service-level

Version-Release number of selected component (if applicable):
[root@dhcp35-180 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.10-1
subscription management rules: 5.20
subscription-manager: 1.17.5-1.git.0.9f499d8.el7
python-rhsm: 1.17.1-1.git.1.323232f.el7


How reproducible:


Steps to Reproduce:
Have multiple installed product certs that are not covered by a single service-level

1.[root@dhcp35-180 ~]# systemctl enable initial-setup-graphical.service 
Created symlink from /etc/systemd/system/graphical.target.wants/initial-setup-graphical.service to /usr/lib/systemd/system/initial-setup-graphical.service.

2.[root@dhcp35-180 ~]# reboot

3.Click on "register to rhsm" on inital-setup panel

4. Enter the server details --> next ---> enter the credentials ---> do not select "manually attach subscriptions after registering" checkbox---> Click on register --->A message saying "No service level will cover all the installed products should be displayed", now click on done button

Actual results:
message under RHSM spoke says "Error during registration" , though system was registered successfully

Expected results:

Message should be something similar to "System is registered successfully but none of the installed products are covered"
Additional info:

Comment 1 Shwetha Kallesh 2016-04-25 10:29:59 UTC
Created attachment 1150399 [details]
Error on RHSM spoke

Comment 4 Shwetha Kallesh 2017-11-10 08:23:00 UTC
Created attachment 1350354 [details]
See the message "System is successfully registered"

Verified!

[root@dhcp35-121 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.5-1.el7

Comment 7 errata-xmlrpc 2018-04-10 09:47:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.