This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 133005 - rsh/rlogin fails to to hang at password prompt
rsh/rlogin fails to to hang at password prompt
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rsh (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 17:17 EDT by Alex Bruno
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 06:19:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Bruno 2004-09-20 17:17:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
Trying to enable rsh/rlogin for root. It work for non root, but when I
try with 
root the session gets created but hangs waiting on password. 
 
/var/log/messages 
 
Sep 13 13:23:38 hbonysec01as pam_rhosts_auth[26288]: allowed to 
root@wizard2.homebox.com as root 
 
--->>> remote system wizard2 hung at password prompt <<<--- 
 
Sep 13 13:32:09 hbonysec01as pam_rhosts_auth[26357]: allowed to 
gnikovit@wizard2.homebox.com as gnikovit 
Sep 13 13:32:09 hbonysec01as login(pam_unix)[26358]: session opened
for user 
gnikovit by (uid=0) 
Sep 13 13:32:09 hbonysec01as login -- gnikovit[26358]: LOGIN ON pts/1 BY 
gnikovit FROM wizard2.homebox.com 
Sep 13 13:38:02 hbonysec01as login(pam_unix)[26358]: session closed
for user 
gnikovit 
 
--->>> rsh worked from wizard2 system for my id <<<--- 
 
 
Sep 13 13:38:13 hbonysec01as pam_rhosts_auth[26443]: allowed to 
root@wizard2.homebox.com as root 
 
--->>> Again hung from wizard2 system at password prompt <<<--- 
 
Sep 13 13:38:13 hbonysec01as pam_rhosts_auth[26443]: allowed to 
root@wizard2.homebox.com as root 
 
 
 
--->>> /etc/pam.d/rsh 
#%PAM-1.0 
# For root login to succeed here with pam_securetty, "rsh" must be 
# listed in /etc/securetty. 
auth       required     pam_nologin.so 
# auth       required   pam_securetty.so 
auth       required     pam_env.so 
auth       required     pam_rhosts_auth.so 
account    required     pam_stack.so service=system-auth 
session    required     pam_stack.so service=system-auth 
 
 
--->>> /etc/pam.d/rlogin <<<--- 
 
#%PAM-1.0 
# For root login to succeed here with pam_securetty, "rlogin" must be 
# listed in /etc/securetty. 
#auth       required    pam_nologin.so 
auth       required     pam_securetty.so 
auth       required     pam_env.so 
auth       sufficient   pam_rhosts_auth.so 
auth       required     pam_stack.so service=system-auth 
account    required     pam_stack.so service=system-auth 
password   required     pam_stack.so service=system-auth 
session    required     pam_stack.so 
*** Notes: DWA@REDHAT.COM  14-SEP-2004 10:30:25

You will need to edit /etc/securetty to include the following lines: 

rsh 
rlogin

Additionally, .rhosts within root's home directory should contain the
hostname of the system which you wish to connect from. 

Please feel free to contact us if you have any additional questions. 

Regards, 
David
*** Notes: HBO-CORP  14-SEP-2004 10:54:18
adding the two entries has solved the problem, but one additional
item.  When 
there is no entry in .rhosts file for the user that issued the rsh he is 
prompted for the password but hangs.  The rlogin process must be
killed or time out. 
 
Is this normal?
*** Notes: DWA@REDHAT.COM  14-SEP-2004 11:01:19
Mr. Nikovits, 

rsh is designed to use the ~/.rhosts file, so it is expected to be
there. The file /etc/hosts.equiv can also be used as a system-wide
rhosts file for non-root users. 

But the question was it normal for a password prompt be presented to
the user 
and hang. Even when he enters the password the logon will not proceed?

I have observed the behavior you described when ~/.rhosts or
/etc/hosts.equiv was not present, so that is expected to happen. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.log into system with rlogin
2.no entry in rhosts file for user who issues rsh
3.prompts for password, but hangs
    

Actual Results:  login impossible due to system hang

Expected Results:  login should provide a valid password prompt
without a hang

Additional info:
Comment 1 Karel Zak 2004-12-15 05:34:36 EST
I cannot reproduce it.

Please, can you check your setting or try strace rlogin? For more
information see:

http://people.redhat.com/kzak/docs/rsh-rlogin-howto.html
Comment 2 Karel Zak 2005-09-08 06:19:50 EDT
No response. NEEDINFO -> CANTFIX

Note You need to log in before you can comment on or make changes to this bug.