Bug 1330052 - [RFE] We need more debug info from stack wind and unwind calls
Summary: [RFE] We need more debug info from stack wind and unwind calls
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Raghavendra Talur
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1330739 1332077
TreeView+ depends on / blocked
 
Reported: 2016-04-25 10:57 UTC by Raghavendra Talur
Modified: 2016-06-16 14:04 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1330739 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:04:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Raghavendra Talur 2016-04-25 10:57:06 UTC
Description of problem:
It is possible that some xlators don't print debug/trace logs even when required.
In such cases debugging an existing setup without recompiling becomes very difficult. If libglusterfs/gluster wind/unwind had a debug log builtin then such dependency on every xlator would be reduced.


Version-Release number of selected component (if applicable):
mainline and all previous versions


How reproducible:
Always

Comment 1 Vijay Bellur 2016-04-25 11:15:07 UTC
REVIEW: http://review.gluster.org/13448 (libglusterfs: Add debug and trace logs for stack trace) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 2 Vijay Bellur 2016-04-27 19:26:35 UTC
COMMIT: http://review.gluster.org/13448 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit c4d67a8338b42d6485f49999f310cbb9ed5359c5
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Mon Feb 15 18:16:04 2016 +0530

    libglusterfs: Add debug and trace logs for stack trace
    
    It has become very difficult to identify the xlator which returned
    negative op_ret. Being able to just change the log level and
    visualize the stack is helpful in such cases.
    
    Change-Id: I6545b4802c1ab4d0d230d5e9e036afb2384882e1
    BUG: 1330052
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/13448
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 3 Niels de Vos 2016-06-16 14:04:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.