Bug 1330091 - broken symlinks to filter_plugins and lookup_plugins
Summary: broken symlinks to filter_plugins and lookup_plugins
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Troy Dawson
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-25 11:58 UTC by Evgheni Dereveanchin
Modified: 2016-09-27 09:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:31:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Evgheni Dereveanchin 2016-04-25 11:58:04 UTC
Description of problem:
The Ansible installer RPM ships with broken symlinks on the following locations:
/usr/share/ansible/openshift-ansible/playbooks/byo/filter_plugins
/usr/share/ansible/openshift-ansible/playbooks/byo/lookup_plugins

Version-Release number of selected component (if applicable):
openshift-ansible-playbooks-3.0.47-6.git.0.7e39163.el7aos.noarch

How reproducible:
 always

Steps to Reproduce:
1. install openshift-ansible-playbooks
2. check the following symlinks:
/usr/share/ansible/openshift-ansible/playbooks/byo/filter_plugins
/usr/share/ansible/openshift-ansible/playbooks/byo/lookup_plugins

Actual results:
 symlinks broken

# ls -la /usr/share/ansible/openshift-ansible/playbooks/byo/filter_plugins
lrwxrwxrwx. 1 root root 20 Apr 13 14:37 /usr/share/ansible/openshift-ansible/playbooks/byo/filter_plugins -> ../../filter_plugins
# ls -la /usr/share/ansible/openshift-ansible/playbooks/byo/lookup_plugins
lrwxrwxrwx. 1 root root 20 Apr 13 14:37 /usr/share/ansible/openshift-ansible/playbooks/byo/lookup_plugins -> ../../lookup_plugins

# cd /usr/share/ansible/openshift-ansible/playbooks/byo/filter_plugins
-bash: cd: /usr/share/ansible/openshift-ansible/playbooks/byo/filter_plugins: No such file or directory
# cd /usr/share/ansible/openshift-ansible/playbooks/byo/lookup_plugins
-bash: cd: /usr/share/ansible/openshift-ansible/playbooks/byo/lookup_plugins: No such file or directory


Expected results:
 symlinks work (or don't even exist if not needed)

Additional info:
 correct symlink destinations probably are:
/usr/share/ansible_plugins/

Comment 1 Brenton Leanhardt 2016-04-25 19:18:35 UTC
I'm sure we could improve the RPM requires for this package. I think the idea is to install the openshift-ansible package and it for to pull in all the dependencies.

Comment 2 Jason DeTiberus 2016-04-25 19:24:38 UTC
I suspect that the default lookup path for lookup_plugins and filter_plugins is what is making things work even with these symlinks being broken. We might just need to exclude these symlinks from the packaging.

Comment 3 Brenton Leanhardt 2016-04-27 15:04:40 UTC
Troy, I don't think we're going to merge this until after other blockers are done but if you want to take a look check this out:

https://github.com/openshift/openshift-ansible/pull/1823

Comment 4 Troy Dawson 2016-04-27 15:42:22 UTC
This is just the tip of the problem.
There are 20 broken links pointing to filter_plugins and 16 pointing to lookup_plugins.

If you are certain that we are find getting rid of these, I can get you a nice find command that will clean them all up.

Comment 5 Brenton Leanhardt 2016-04-27 15:45:22 UTC
That sounds good to me.  Feel free to just put it in a PR that can replace mine.  I think all the broken symlinks need to be removed.  I suspect they are only there because they aren't broken from a git clone and are a workaround for development.

Comment 6 Troy Dawson 2016-04-27 16:09:20 UTC
How does this look

https://github.com/openshift/openshift-ansible/pull/1827

Comment 8 openshift-github-bot 2016-07-12 14:53:02 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/a99b49fb93f1edc4a1c68c472c059e3ed0c91b6b
Merge pull request #1827 from tdawson/201604-broken-symlinks

Bug 1330091 - cleanup broken symlinks - lookup_plugins filter_plugins

Comment 9 Troy Dawson 2016-07-12 14:57:50 UTC
The pull request to fix this bug has been merged.
This is going into the 3.3 installer.  Updating bugzilla appropriately.

Comment 10 Gaoyun Pei 2016-07-18 05:47:11 UTC
Verify this bug with openshift-ansible-playbooks-3.3.2-1.git.0.1223e95.el7.noarch

After package installed, no such broken symlinks any more.

[root@host-192-168-0-68 ~]# ls -al /usr/share/ansible/openshift-ansible/playbooks/byo/filter_plugins
ls: cannot access /usr/share/ansible/openshift-ansible/playbooks/byo/filter_plugins: No such file or directory
[root@host-192-168-0-68 ~]# ls -al /usr/share/ansible/openshift-ansible/playbooks/byo/lookup_plugins
ls: cannot access /usr/share/ansible/openshift-ansible/playbooks/byo/lookup_plugins: No such file or directory

Comment 12 errata-xmlrpc 2016-09-27 09:31:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.