Bug 1330096 - Xiphos is installed incorrectly by gnome-software
Summary: Xiphos is installed incorrectly by gnome-software
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xiphos
Version: 23
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: greg.hellings
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-25 12:04 UTC by Ervin
Modified: 2016-06-18 18:49 UTC (History)
3 users (show)

Fixed In Version: xiphos-4.0.4-4.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-18 18:49:23 UTC


Attachments (Terms of Use)

Description Ervin 2016-04-25 12:04:05 UTC
Description of problem:
When installing Xiphos from gnome-software, only Xiphos common files for all versions of Xiphos are installed, not the gui, neither the gtk2 or gtk3. Therefore Xiphos is not truly installed as a functioning program. 

Version-Release number of selected component (if applicable):
Version of Xiphos = 4.0.4-1.fc23
Gnome Software version = 3.18.3

How reproducible:
Always


Steps to Reproduce:
1. Open Gnome-software and install Xiphos from there
2. Try to launch Xiphos. 
3. Open Yumex (or install Yumex not Yumex-Dnf) and browse for Xiphos there. 

Actual results:
Xiphos common files for all versions of Xiphos are installed, but not the Xiphos gkt2 or gkt3. 


Expected results: The data files should be installed and the the most compatible version of gtk for Xiphos with the current operating system installed as well. 


Additional info:
The bug could be in Xiphos too, even after installing xiphos gtk2 or xiphos gtk3 xiphos fails to show and launch. Please assign the bug accordingly.

Comment 1 greg.hellings 2016-06-01 14:33:10 UTC
This seems like a problem with gnome-software, not with Xiphos itself or the Xiphos packaging. But I don't even know where to begin asking that question. Let me poke around, if possible.

Comment 2 greg.hellings 2016-06-01 15:11:31 UTC
Hmm, further digging seems to indicate this is because I ship the xiphos.appdata.xml file in the -common. This file appears to be the one that gnome-software thinks indicates the particular image is a GUI application to be installed. I can't properly set that file to be included in BOTH of the -gtk2 and -gtk3 packages. I'll probably have to get around it by setting some sort of dependency between the packages. Let me reach out to the rest of the Fedora dev team to see what is the best way forward.

Comment 3 Fedora Update System 2016-06-02 12:47:19 UTC
xiphos-4.0.4-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-83cd08f35e

Comment 4 Fedora Update System 2016-06-03 09:26:47 UTC
xiphos-4.0.4-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-83cd08f35e

Comment 5 Fedora Update System 2016-06-18 18:49:21 UTC
xiphos-4.0.4-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.