Bug 13301 - XFree-3.3 servers give XKB errors when parsing keymaps
XFree-3.3 servers give XKB errors when parsing keymaps
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Depends On:
  Show dependency treegraph
Reported: 2000-06-30 17:48 EDT by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-07-07 17:20:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-06-30 17:48:46 EDT
I'm still using XFree86-SVGA with beta2 since XFree-4.0 still gives me
trouble (already in bugzilla)

XFree86-SVGA gives the following errors:
error opening security policy file
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:            Can't find file "us" for symbols include
>                   Exiting
>                   Abandoning symbols file "default"
Errors from xkbcomp are not fatal to the X server
Couldn't load XKB keymap, falling back to pre-XKB keymap

Although these error are not fatal, they do cause backspace to be del in
all xprograms which is sorta annoying.
Comment 1 Jeremy Katz 2000-07-02 01:12:48 EDT
This is still broken in the -29 XFree RPM snapshots on gribble
Comment 2 Hans de Goede 2000-07-07 17:19:59 EDT
This is fixed in beta3

Note You need to log in before you can comment on or make changes to this bug.