Bug 133010 - intel 815 graphical netboot install strange display
intel 815 graphical netboot install strange display
Status: CLOSED DUPLICATE of bug 132267
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Triaged
Depends On:
Blocks: FC4Blocker FC3Update
  Show dependency treegraph
 
Reported: 2004-09-20 17:49 EDT by François Kooman
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
just before X starts (61.76 KB, image/png)
2004-09-20 17:50 EDT, François Kooman
no flags Details
strange X display (81.56 KB, image/png)
2004-09-20 17:50 EDT, François Kooman
no flags Details
dmesg (13.69 KB, text/plain)
2004-10-13 03:48 EDT, François Kooman
no flags Details
Xorg logfile (33.75 KB, text/plain)
2004-10-13 03:49 EDT, François Kooman
no flags Details
Xorg config file (2.90 KB, text/plain)
2004-10-13 03:50 EDT, François Kooman
no flags Details

  None (edit)
Description François Kooman 2004-09-20 17:49:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
I tried installing the FC3-test2 on my notebook (Fujitsu Siemens
Lifebook with onboard Intel 815 video) but it seems the i810 driver is
broken. Everything works until the X server starts, after that the
strange window shows up (see attached screenshots, I apologize for the
bad quality).

I tried booting with acpi=off which seems to work at first, but it
just delays the effect (just at selecting firewall settings the same
effect shows up)

When the strange window shows up I'm unable to use ctrl+alt+f1..f4 or
ctrl+alt+backspace or ctrl+alt+del, system is still pingable.

Version-Release number of selected component (if applicable):
xorg-x11 from fc3-test2

How reproducible:
Always

Steps to Reproduce:
1. boot the FC3-t2 boot.iso image
2. enter network info, choose mirror
3. wait for X to come up
    

Actual Results:  strange display (see screenshots) without the ability
to continue the install

Expected Results:  normal X based installation

Additional info:

(obtained using FC2, which works great): 

00:02.0 VGA compatible controller: Intel Corp. 82815 CGC [Chipset
Graphics Controller] (rev 11) (prog-if 00 [VGA])
        Subsystem: Fujitsu Limited.: Unknown device 110c
        Flags: bus master, 66Mhz, medium devsel, latency 0, IRQ 10
        Memory at f8000000 (32-bit, prefetchable)
        Memory at f4000000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [dc] Power Management version 2
Comment 1 François Kooman 2004-09-20 17:50:11 EDT
Created attachment 104037 [details]
just before X starts
Comment 2 François Kooman 2004-09-20 17:50:41 EDT
Created attachment 104038 [details]
strange X display
Comment 3 Marek Kassur 2004-09-21 16:13:32 EDT
Just boot with resolution 800x600, it works for me.

Hardware info:
Intel D815EEA, 352MB RAM.
Comment 5 Jim Cornette 2004-09-22 07:16:44 EDT
I experienced this error when trying the install in graphical mode
from the CDROMs for FC3T2. The screenshot shows the distortion that
happens when trying the installation.
To exit the installer when this error happens, pressing alt-sysreq-b
allows an immediate break from the installer.

I didn't try passing 800 x 600 resolution to the installer before
attempting the GUI installation. If the need for designating the
specific resolution at boot is needed, then adding this behavior to
the installer would probably be a wise choice. not many people
attempting installations would think to specify a screen resolution
before atempting an installation.

The effected graphics version is:
VGA compatible controller: Intel Corp. 82815 CGC [Chipset Graphics
Controller] (rev 02) 
Comment 6 Marek Kassur 2004-09-26 19:23:47 EDT
I've updated my system to current development tree, after that this
distortion back again causes console lockup. However, I can login
remotely and do all my things as normal.
Comment 7 Marek Kassur 2004-10-01 18:36:59 EDT
Here is interesting part of Xorg log:

(II) I810(0): [drm] DRM interface version 1.2
(II) I810(0): [drm] created "i810" driver at busid "pci:0000:00:02.0"
(II) I810(0): [drm] added 8192 byte SAREA at 0x1897e000
(II) I810(0): [drm] mapped SAREA 0x1897e000 to 0xf6f93000
(II) I810(0): [drm] framebuffer handle = 0xf8000000
(II) I810(0): [drm] added 1 reserved context for kernel
(II) I810(0): [drm] Registers = 0xffa80000
(II) I810(0): [agp] dcacheHandle : 0x0
(II) I810(0): [agp] GART: no dcache memory found
(II) I810(0): [agp] Bound backbuffer memory
(II) I810(0): [agp] Bound depthbuffer memory
(II) I810(0): [agp] Bound System Texture Memory
(II) I810(0): [agp] GART: Allocated 4K for mouse cursor image
(II) I810(0): [agp] GART: Allocated 16K for ARGB mouse cursor image
(II) I810(0): Adding 768 scanlines for pixmap caching
(II) I810(0): Allocated Scratch Memory
(II) I810(0): [dri] Buffer map : 3fb000
(II) I810(0): [drm] added 256 4096 byte DMA buffers
(II) I810(0): [drm] Init v1.4 interface.
(II) I810(0): [drm] dma control initialized, using IRQ -1007
(II) I810(0): [dri] visual configs initialized.
(==) I810(0): Write-combining range (0xf8000000,0x4000000)
(II) I810(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is
0x0000
pgetbl_ctl: 0x15010001 pgetbl_err: 0x0
ipeir: 0 iphdr: cc9d8b00
LP ring tail: 48 head: 8 len: f001 start 2300000
eir: 0 esr: 1 emr: 3d
instdone: ff7a instpm: 0
memmode: 4 instps: 10
hwstam: 9ac7 ier: 0 imr: 9ac7 iir: 0

Fatal server error:
Active ring not flushed
Comment 8 Mike A. Harris 2004-10-12 19:00:58 EDT
Please try a text mode install, so you can get to a system prompt
after installation, and then once you've rebooted into the new
OS install, log in as root and run "system-config-display --reconfig".

Now run "startx" and report back what the results are.  Once
you've tested this, please attach the X server log, config file,
and /var/log/messages to the report as individual uncompressed
file attachments using the link below and we will review the
information and try to troubleshoot the issue further.

After you've tested that, please try disabling Red Hat Graphical
Boot (rhgb) by modifying your grub.conf or modifying the kernel
commandline inside grub.  Then reboot the system and let it
start up without rhgb.  When rhgb does not start, does the problem
go away at all?

Setting bug status to "NEEDINFO"
Comment 10 François Kooman 2004-10-13 03:47:49 EDT
- I installed FC3t3 with the textmode installer
- Everything seems to work (rhgb, firstboot, X) with 800x600 resolution
- Selected 1024x768 screen resolution
- restarted X, everything worked
- updated system to rawhide, reboot
- X (at gdm time) failed to start, rhgb worked though
- system-config-display --reconfig
- selected tft panel 1024x768
- chose resolution 1024x768
- reboot
- disabled rhgb @ boot
- working @ 1024x768 with i810 driver
- I'll try using it for a time and see what happens

Attached dmesg, xorg.conf, Xorg.0.org (there is a drm warning at the
end of dmesg...)
Comment 11 François Kooman 2004-10-13 03:48:35 EDT
Created attachment 105116 [details]
dmesg
Comment 12 François Kooman 2004-10-13 03:49:26 EDT
Created attachment 105117 [details]
Xorg logfile
Comment 13 François Kooman 2004-10-13 03:50:02 EDT
Created attachment 105118 [details]
Xorg config file
Comment 14 François Kooman 2004-10-13 03:58:38 EDT
There are some strange messages shown by dmesg:

[drm:i810_wait_ring] *ERROR* space: 65520 wanted 65528
[drm:i810_wait_ring] *ERROR* lockup
[drm:i810_wait_ring] *ERROR* space: 65512 wanted 65528
[drm:i810_wait_ring] *ERROR* lockup
[drm:i810_wait_ring] *ERROR* space: 65504 wanted 65528
[drm:i810_wait_ring] *ERROR* lockup
[drm:i810_wait_ring] *ERROR* space: 65496 wanted 65528
[drm:i810_wait_ring] *ERROR* lockup
mtrr: base(0xf8000000) is not aligned on a size(0x180000) boundary
[drm] Using v1.4 init.

glxinfo shows DRI enabled, glxgears works (200 fps @ celeron 850)
Comment 15 Mike A. Harris 2004-10-13 07:08:39 EDT
> - X (at gdm time) failed to start, rhgb worked though
> - disabled rhgb @ boot
> - working @ 1024x768 with i810 driver

This sounds to me like a problem we're observing.  In previous
OS releases, we started rhgb in it's own X server, which then
quit, and started the real X server.  Now, it attempts to start
a second X server while the first is still running, in order
to speed up boot time.  This causes 2 problems:

1) The first X server (the rhgb one) gets DRI support, and the
   second and subsequent X servers get disabled DRI because DRI
   only works on one X server (limitation).

2) Many video drivers were never designed, implemented, and
   rigorously tested to work in systems with multiple X servers
   running.

As a result of #2, we are hitting bugs and limitations in the
X server and video drivers that would not ordinarily surface
for normal users running one X server.

For comment #14, that may or may not be related to this problem,
as that is a common error that occurs in the Intel driver which
seems to have eluded X.Org and XFree86 i810 developers for 3 years
or so now.  ;o)  Does the error go away if you disable rhgb and
reboot, or does it occur always?

Comment 16 Mike A. Harris 2004-10-13 07:10:26 EDT
Oh, forgot to mention..  We're currently evaluating the ramifications
of starting 2 X servers simultaneously to speed up booting and wether
it is worth the risk of instabilities in some drivers with some users.

We'll hopefully have a solution to this for FC3.  I'll provide status
updates as we progress.

Thanks.
Comment 17 François Kooman 2004-10-13 13:48:43 EDT
With rhgb disabled the "warnings" disappear. 

It's strange I can't install FC with the graphical installer (fc3t3
installer turns the screen green at about the root password dialog. No
rainbow effect this time) but use X with the i810 driver after the
install. Something changed in the kernel / Xorg packages recently? 
Comment 18 Mike A. Harris 2004-10-13 14:25:00 EDT
Which warnings disappear specifically?
Comment 19 François Kooman 2004-10-13 14:37:32 EDT
Woops, I meant the errors reported by dmesg:

[drm:i810_wait_ring] *ERROR* space: 65520 wanted 65528
[drm:i810_wait_ring] *ERROR* lockup
[drm:i810_wait_ring] *ERROR* space: 65512 wanted 65528
[drm:i810_wait_ring] *ERROR* lockup
[drm:i810_wait_ring] *ERROR* space: 65504 wanted 65528
[drm:i810_wait_ring] *ERROR* lockup
[drm:i810_wait_ring] *ERROR* space: 65496 wanted 65528
[drm:i810_wait_ring] *ERROR* lockup
Comment 20 Marek Kassur 2004-10-13 14:48:39 EDT
In the meantime I've installed FC3T3 also in text mode, as graphical
installer lockup with black screen. I'd like to mention that adding
Option “NoAccel” to xorg.conf solves the issue as well.
Comment 22 Dennis Björklund 2004-11-10 07:34:43 EST
I had the same problem with an i815 (motherboard GigaByte GA-6OMM7E)
and the final FC3. NoAccel solved it for me as well. Thanks for that hint.

Also, I had to install using the text mode and have turned of rhgb.
Comment 23 Mike A. Harris 2004-11-10 15:46:28 EST

*** This bug has been marked as a duplicate of 132267 ***
Comment 24 Alejandro Gonzalez Hernandez - Imoq 2004-11-10 17:11:47 EST
I can confirm this bug on an i810 video with Fedora Core 3, trying to
upgrade from Fedora Core 2. I'll try to install in text mode tonight
and add the "NoAccel" option to x.org and report it back.
Comment 25 James Thorne 2004-11-17 10:26:13 EST
Installing FC3 in text mode and adding "NoAccel" to the i815 device
section of /etc/X11/xorg.conf does indeed fix the problem on FC3.
Comment 26 Alejandro Gonzalez Hernandez - Imoq 2004-11-17 10:36:31 EST
You really should see bug #132267
Comment 27 Dennis Maeder 2005-01-01 21:42:14 EST
All I needed was the "NoAccel" adjustment to fix a crazy X interface
after upgrade from FC2 to FC3. e.g. Windows would open but not
refresh. Text would not scroll properly. Only some menus would drop down.
Thank you Marek Kassur!
Perhaps NoAccel should be default for this driver?
Comment 28 François Kooman 2006-01-30 10:28:59 EST
Bug is back in Rawhide 2006-01-30. I tried to install Rawhide on my laptop and
at the moment anaconda formats the harddisk the screen is in the funny rainbow
state as described by this bug.
Comment 29 Red Hat Bugzilla 2006-02-21 14:05:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.