Bug 1330123 - AttributeError: 'NoneType' object has no attribute 'order' on terminal
Summary: AttributeError: 'NoneType' object has no attribute 'order' on terminal
Keywords:
Status: CLOSED DUPLICATE of bug 1268094
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-25 12:32 UTC by Rehana
Modified: 2016-06-06 19:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-06 19:33:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rehana 2016-04-25 12:32:04 UTC
Description of problem:


Version-Release number of selected component (if applicable):
# subscription-manager version
server type: This system is currently not registered.
subscription management server: 2.0.10-1
subscription management rules: 5.20
subscription-manager: 1.17.5-1.git.0.9f499d8.el7
python-rhsm: 1.17.1-1.git.1.323232f.el7


How reproducible:
3/3

Steps to Reproduce:
1.launch subscription-manager-gui
2.Register and auto-attach subscriptions
3.Unregister from the GUI 
3.

Actual results:
 subscription-manager-gui
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/widgets.py", line 313, in _selection_callback
    self.on_selection(selection)
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 269, in on_selection
    order = cert.order
AttributeError: 'NoneType' object has no attribute 'order'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/widgets.py", line 313, in _selection_callback
    self.on_selection(selection)
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 269, in on_selection
    order = cert.order
AttributeError: 'NoneType' object has no attribute 'order'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/widgets.py", line 313, in _selection_callback
    self.on_selection(selection)
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 269, in on_selection
    order = cert.order
AttributeError: 'NoneType' object has no attribute 'order'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/widgets.py", line 313, in _selection_callback
    self.on_selection(selection)
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 269, in on_selection
    order = cert.order
AttributeError: 'NoneType' object has no attribute 'order'

Observed a track back on cli

Expected results:
No traceback

Additional info:

Comment 5 Chris Snyder 2016-06-06 19:33:13 UTC
I suspect that the following commit fixed the issue seen here:

https://github.com/candlepin/subscription-manager/commit/936c7ba18fcc9055928e9db43aa592b589c0547d

It appears this bug is a duplicate of this one: https://bugzilla.redhat.com/show_bug.cgi?id=1268094


Closing as a duplicate as the above bug is verified.

*** This bug has been marked as a duplicate of bug 1268094 ***


Note You need to log in before you can comment on or make changes to this bug.