Bug 1330231 - pssh fails with "ValueError: the fd 5 must be in non-blocking mode"
Summary: pssh fails with "ValueError: the fd 5 must be in non-blocking mode"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pssh
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-25 16:50 UTC by nucleo
Modified: 2016-05-16 14:55 UTC (History)
2 users (show)

Fixed In Version: pssh-2.3.1-14.fc24 pssh-2.3.1-14.fc23 pssh-2.3.1-14.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-07 11:52:45 UTC
Type: Bug


Attachments (Terms of Use)

Description nucleo 2016-04-25 16:50:21 UTC
Version-Release number of selected component (if applicable):
pssh-2.3.1-13.fc24.noarch

Steps to Reproduce:
$ pssh -i -l root -H 192.168.0.1 df

Actual results:
Traceback (most recent call last):
  File "/usr/bin/pssh", line 118, in <module>
    do_pssh(hosts, cmdline, opts)
  File "/usr/bin/pssh", line 71, in do_pssh
    manager = Manager(opts)
  File "/usr/lib/python3.5/site-packages/psshlib/manager.py", line 42, in __init__
    self.iomap = IOMap()
  File "/usr/lib/python3.5/site-packages/psshlib/manager.py", line 215, in __init__
    signal.set_wakeup_fd(wakeup_writefd)
ValueError: the fd 5 must be in non-blocking mode


Additional info:
Looks like this is python-3.5 related problem.

See bug https://bugs.archlinux.org/task/46571
Fix provided there https://github.com/nplanel/parallel-ssh/commit/ee379dc5c69e4e0f62f92fb48f9a9ce6af0b2ac4.patch

Comment 1 Terje Røsten 2016-04-25 18:07:10 UTC
Thanks for report and fix.

Comment 2 Fedora Update System 2016-04-25 18:32:53 UTC
pssh-2.3.1-14.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c0917906e6

Comment 3 Fedora Update System 2016-04-25 18:32:59 UTC
pssh-2.3.1-14.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1c0547b55b

Comment 4 Fedora Update System 2016-04-25 18:33:04 UTC
pssh-2.3.1-14.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e3e69a0f19

Comment 5 Fedora Update System 2016-04-26 16:23:06 UTC
pssh-2.3.1-14.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1c0547b55b

Comment 6 Fedora Update System 2016-04-27 01:21:31 UTC
pssh-2.3.1-14.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c0917906e6

Comment 7 Fedora Update System 2016-04-27 01:21:54 UTC
pssh-2.3.1-14.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e3e69a0f19

Comment 8 Fedora Update System 2016-05-07 11:52:43 UTC
pssh-2.3.1-14.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-05-15 05:32:07 UTC
pssh-2.3.1-14.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-05-16 14:55:32 UTC
pssh-2.3.1-14.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.