Bug 133028 - Upgrade to bind-9.2.4-EL3_10 doesn't work for a chroot'ed environment
Upgrade to bind-9.2.4-EL3_10 doesn't work for a chroot'ed environment
Status: CLOSED DUPLICATE of bug 131803
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bind (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 18:46 EDT by Christopher C. Weis
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher C. Weis 2004-09-20 18:46:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040614 Firefox/0.9

Description of problem:
When upgrading to bind-9.2.4-EL3_10 via up2date, the chroot'ed
environment doesn't upgrade correctly.  In the aftermath,
/etc/sysconfig/network needs to be fixed, as well as
/var/named/chroot/etc/*.  Also, the init script's named-checkconf line
doesn't look for the named.conf in the chrooted environment.

Version-Release number of selected component (if applicable):
Upgrade to bind-9.2.4-EL3_10

How reproducible:
Always

Steps to Reproduce:
1. Update bind via up2date (possibly via 'rpm -U' command-line as well)
2. Watch the init script complain of a missing "/etc/named.conf"
script and fail to start the named service.
3.
    

Actual Results:  Named didn't start at all

Expected Results:  Named would start in a chroot'ed environment

Additional info:
Comment 1 Jason Vas Dias 2004-09-20 19:13:26 EDT
Yes, sorry - this bug has been found before: bug #131803 .
The problem was with the bind-chroot-9.2.2-21 %postun script,
which removes these files under the chroot during upgrade: 
 etc/named.conf, etc/rndc.key, and some dev/ files.
The fix is to restore your named.conf (which should be 
saved as named.conf.rpmsave) and rndc key, and then
upgrade to the fix for RHEL-3-U3, which  will be
in RHEL-3-U4, but which meanwhile is at:
http://people.redhat.com/jvdias/bind/RHEL-3/9.2.4rc7-12_EL3



*** This bug has been marked as a duplicate of 131803 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.