Bug 1330318 - rpm-ostree status error: Error calling StartServiceByName for org.projectatomic.rpmostree1: Timeout was reached
Summary: rpm-ostree status error: Error calling StartServiceByName for org.projectatom...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 24
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException https://fedor...
Keywords: CommonBugs
: 1332119 1333176 (view as bug list)
Depends On:
Blocks: F24BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-04-25 21:08 UTC by Chris Murphy
Modified: 2016-05-14 23:27 UTC (History)
15 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-14 23:27:59 UTC


Attachments (Terms of Use)

Description Chris Murphy 2016-04-25 21:08:34 UTC
Description of problem:

Command fails after 30 second hang.

Version-Release number of selected component (if applicable):
rpm-ostree-2015.11-2.fc24.x86_64


How reproducible:
Always

Steps to Reproduce:
1. rpm-ostree status
2.
3.

Actual results:

error: Error calling StartServiceByName for org.projectatomic.rpmostree1: Timeout was reached


Expected results:

Status


Additional info:

Apr 25 15:06:30 localhost.localdomain dbus[861]: [system] Activating via systemd: service name='org.projectatomic.rpmostree1' unit='rpm-ostreed.service'
Apr 25 15:06:30 localhost.localdomain audit[1191]: AVC avc:  denied  { execute } for  pid=1191 comm="(-ostreed)" name="rpm-ostreed" dev="dm-0" ino=1585 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:install_exec_t:s0 tclass=file permissive=0
Apr 25 15:06:30 localhost.localdomain audit[1191]: SYSCALL arch=c000003e syscall=59 success=no exit=-13 a0=5557d3394e20 a1=5557d334f7f0 a2=5557d33954c0 a3=5557d338bc90 items=0 ppid=1 pid=1191 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="(-ostreed)" exe="/usr/lib/systemd/systemd" subj=system_u:system_r:init_t:s0 key=(null)
Apr 25 15:06:30 localhost.localdomain audit: PROCTITLE proctitle="(-ostreed)"
Apr 25 15:06:30 localhost.localdomain systemd[1]: Starting RPM OSTree Manager...
Apr 25 15:06:30 localhost.localdomain systemd[1191]: rpm-ostreed.service: Failed at step EXEC spawning /usr/libexec/rpm-ostreed: Permission denied
Apr 25 15:06:30 localhost.localdomain systemd[1]: rpm-ostreed.service: Main process exited, code=exited, status=203/EXEC
Apr 25 15:06:30 localhost.localdomain systemd[1]: Failed to start RPM OSTree Manager.
Apr 25 15:06:30 localhost.localdomain systemd[1]: rpm-ostreed.service: Unit entered failed state.
Apr 25 15:06:30 localhost.localdomain audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=rpm-ostreed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Apr 25 15:06:30 localhost.localdomain systemd[1]: rpm-ostreed.service: Failed with result 'exit-code'.
Apr 25 15:06:55 localhost.localdomain dbus[861]: [system] Failed to activate service 'org.projectatomic.rpmostree1': timed out

Comment 1 Chris Murphy 2016-04-25 21:10:16 UTC
Installed to a libvirt VM with Fedora-Atomic-dvd-x86_64-24-20160424.n.0.iso which pulled down tree 24.16.

Comment 2 Colin Walters 2016-04-25 21:25:28 UTC
This needs a policy change.

Comment 3 Fedora Blocker Bugs Application 2016-04-25 21:46:14 UTC
Proposed as a Freeze Exception for 24-beta by Fedora user walters using the blocker tracking app because:

 The update system doesn't start for Atomic Host.

Comment 4 Chris Murphy 2016-04-25 22:04:05 UTC
+1FE

Comment 5 Adam Williamson 2016-04-29 17:02:09 UTC
I think Dennis said something along the lines that Atomic would not ship with Beta, instead it would have it's own 2-week-y release process. Still, I guess it would make sense to push a fix for this so we can work on the composes, so +1 FE.

Comment 6 Stephen Gallagher 2016-05-02 12:18:46 UTC
+1 FE

Comment 7 Adam Williamson 2016-05-02 15:07:01 UTC
as we have a 1.4 build without this, tagging as CommonBugs...

Comment 8 Tim Flink 2016-05-02 16:27:02 UTC
Discussed at the 2016-05-02 blocker review meeting:

Accepted as a Freeze Exception for F24 Beta because this causes a significant problem in the Atomic images and we must push the fix stable to remedy that. The fix should be safe per selinux-policy update policies, so this is accepted as a freeze exception

Comment 9 Colin Walters 2016-05-02 16:29:48 UTC
*** Bug 1332119 has been marked as a duplicate of this bug. ***

Comment 10 Colin Walters 2016-05-04 21:09:05 UTC
*** Bug 1333176 has been marked as a duplicate of this bug. ***

Comment 11 Lukas Slebodnik 2016-05-04 21:49:21 UTC
It should be fixed in selinux-policy-3.13.1-185.fc24.
But I can reproduce it with -186 on rawhide

-bash-4.3# rpm -q rpm-ostree selinux-policy
rpm-ostree-2016.1-3.fc25.x86_64
selinux-policy-3.13.1-186.fc25.noarch

Is fixed version somewhere in koji?
either for f24 or rawhide

Comment 13 Lukas Slebodnik 2016-05-05 12:08:19 UTC
(In reply to Lukas Vrabec from comment #12)
> Hi Lukas,
>
Thank you very much Lukas for fast response :-)

> Rawhide:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=760201
>
I tested fedora rawhide ostree with selinux policy from this koji build
(selinux-policy-3.13.1-187.fc25) and it fixed bug for me.

Comment 14 Lukas Vrabec 2016-05-05 13:06:24 UTC
Great! Thank you for testing.

Comment 15 kushaldas@gmail.com 2016-05-10 06:48:56 UTC
I am having the same issue while doing F24 nightly image test on the cloud test day.

# rpm-ostree status
error: Error calling StartServiceByName for org.projectatomic.rpmostree1: Timeout was reached

Comment 16 Suraj Narwade 2016-05-10 10:48:51 UTC
I am facing same issue on Fedora 24 atomic host on cloud test day.

$ sudo rpm-ostree status
error: Error calling StartServiceByName for org.projectatomic.rpmostree1: Timeout was reached

Comment 17 Lukas Slebodnik 2016-05-10 11:03:51 UTC
Lukas,
could you push selinux-policy-3.13.1-185.fc24 into fedora 24 testing?

Comment 20 Fedora Update System 2016-05-12 09:42:59 UTC
selinux-policy-3.13.1-185.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0f4619cd21

Comment 21 Fedora Update System 2016-05-14 23:27:38 UTC
selinux-policy-3.13.1-185.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.