Bug 133035 - authconfig fails to properly enable NIS authentification
Summary: authconfig fails to properly enable NIS authentification
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-21 01:44 UTC by Eugene Kanter
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 4.6.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 12:36:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eugene Kanter 2004-09-21 01:44:04 UTC
Description of problem:


Version-Release number of selected component (if applicable):

authconfig-4.6.4-3.src.rpm

How reproducible:

always

Steps to Reproduce:
1. install fresh sytem in NIS network where auto.master and auto.home
are used.
2. follow firstboot and enable NIS authentification.
3. login to X
  
Actual results:

"you home directory /home/xxxxx is not available....."

Expected results:

no errors.

Additional info:

authconfig does good job starting pormapper and ypbind. however autofs
needs to be restarted after ypbind is launched to pick up NIS
automounter maps.
I suspect that autofs needs to be restarted when any changes are made
to pick up new maps from for example LDAP.
Any other services needs to be restarted?

Comment 1 Jindrich Novy 2004-09-21 07:15:45 UTC
Hello Eugene,

I know about this bug and I'm not quite sure if it is a failure of
firstboot or authconfig. I assume you used authconfig-gtk.py called
from firstboot? In that case autofs won't be restarted when autofs is
not running at the time authconfig is executed (authconfig-gtk.py uses
autofs --condrestart)

Have you autofs running at the time the NIS authentizationis enabled
by authconfig?

Can you please write me if the same problem occurs when you use
text-mode authconfig to startup NIS authentication?

Jindrich

Comment 2 Eugene Kanter 2004-09-21 15:23:17 UTC
Hello Jindirch,

autofs will not run after fresh install because "no mount point
configured". authconfig text or gtk mode will have to (re) start
autofs if NIS (or any other authentification which potentially can
provide new mount points) is turned on so autofs has a chance to query
new map and find its new mount points if configured.
likewise if NIS is shut down autofs may have to be restarted as well
to refresh its map list.


Note You need to log in before you can comment on or make changes to this bug.