This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 133043 - Regression: date fields contain ####, works fine on 1.1.0
Regression: date fields contain ####, works fine on 1.1.0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 23:46 EDT by Ben Smith
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 08:12:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test document (20.00 KB, application/vnd.ms-excel)
2004-09-20 23:49 EDT, Ben Smith
no flags Details

  None (edit)
Description Ben Smith 2004-09-20 23:46:06 EDT
Description of problem:
The attached document opens fine in 1.1.0-16 (fc1).  In FC3T1, many of
the date fields simply contain hash marks (####).  The document also
opens fine in Excel XP, but in Excel the fields in question aren't
recognized as Date fields, but as Text fields with 'custom' MM/DD/YYYY
formatting.  I don't know how the document was created but it was
probably originally made on Excel 97.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-6.i386.rpm

How reproducible:
100%

Steps to Reproduce:
1. open the attached document in Openoffice Calc
2. note date fields are filled with #####
  
Actual results:
hash marks

Expected results:
dates formatted in the MM/DD/YYYY format
Comment 1 Ben Smith 2004-09-20 23:49:01 EDT
Created attachment 104055 [details]
Test document
Comment 2 Ben Smith 2004-09-20 23:53:01 EDT
Oh, I forgot, this seems to have only begun to happen when the
document in question was exported from OO.o in .xls format.  I've
recreated the problem by saving other documents (that worked fine
before) from OO.o as .xls type.
Comment 3 Ben Smith 2004-09-21 00:05:36 EDT
Doh!  The "bug" seems to be that the column widths aren't wide enough.
 When the columns are expanded, the correct dates appear.
Comment 4 Caolan McNamara 2005-01-27 08:12:54 EST
Yeah, its not a bug with date per-se, but what happens when the column isn't
wide enough for the text. The font substitution matters here, so the available
fonts determine what happens. The font is "Arial" which isn't available, so the
closest one is used, and its too wide. There's nothing we can really do about that.

Note You need to log in before you can comment on or make changes to this bug.