Bug 133050 - yum -c <file> dumps trace when <file> does not exist.
Summary: yum -c <file> dumps trace when <file> does not exist.
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-21 06:14 UTC by Ralf Corsepius
Modified: 2014-01-21 22:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:27:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2004-09-21 06:14:38 UTC
Description of problem:
yum -c <file> dumps trace when <file> does not exist. 

Version-Release number of selected component (if applicable):
yum-2.1.3-1

How reproducible:
Deterministic.

Steps to Reproduce:
yum -c /etc/non-existing-file check-update
  
Actual results:
yum -c /etc/nonexist check-update
Traceback (most recent call last):
  File "/usr/share/yum-cli/yummain.py", line 139, in ?
    main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 52, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 122, in getOptionsConfig
    self.conf = yumconf(configfile = yumconffile, root=root)
  File "/usr/lib/python2.3/site-packages/yum/config.py", line 65, in
__init__
    configh = confpp(configfile)
  File "/usr/lib/python2.3/site-packages/yum/config.py", line 472, in
__init__
    fo = self._pushfile( url )
  File "/usr/lib/python2.3/site-packages/yum/config.py", line 571, in
_pushfile
    raise Errors.ConfigError, \
AttributeError: confpp instance has no attribute 'name'

Expected results:
Proper error message.

Additional info:
This is with FC3test2's yum-rpm installed on an otherwise clean FC2
system.

Installing the FC3test2 yum-rpm went without any complaint, so if this
issue should be caused by a python incompatibility this breakdown
would indicate a packaging bug.

Comment 1 Seth Vidal 2004-09-21 06:27:40 UTC
This was just a plain old bug.
It's fixed in cvs.

I'd like to add a thank you for a clear and descriptive bug.


Comment 2 Ralf Corsepius 2004-09-21 06:56:46 UTC
So there is hope to see this fixed for FC3 final?

I'd expect newbies to hit this issue not too seldom.


Comment 3 Seth Vidal 2004-09-21 06:58:17 UTC
oh definitely.

I'll have a 2.1.4 out in a day or two - it won't be perfect but it
will fix a number of bugs and implement some new things.

I don't expect that fc3 will be released with anything less than 2.1.8
or higher :)



Note You need to log in before you can comment on or make changes to this bug.