Bug 133052 - yum --download-only install non-functional
yum --download-only install non-functional
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-21 03:33 EDT by Ralf Corsepius
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 09:11:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2004-09-21 03:33:09 EDT
Description of problem:
yum -c <somefile> --download-only install package

performs an actual "installation" instead of "downloading only"

Version-Release number of selected component (if applicable):
yum-2.1.3-1

How reproducible:
Deterministic

Steps to Reproduce:
# rpm -q alsa-lib
alsa-lib-1.0.3a-2

# yum -c /etc/yum.testing --download-only install alsa-lib
...
[/etc/yum.testing only contains a reference to a FC3test3 repository]

# rpm -q alsa-lib
alsa-lib-1.0.6-1
  
Actual results:
see above. Yum seems to ignore --download-only.

Expected results:
Yum to download all requested files, but not to install them, rsp. yum
to complain about it being passed a non-valid option.

Additional info:
This is on a clean FC2 system with FC3test3's yum-rpm installed, while
experimenting with using yum-2.1.3 to upgrade from FC2 to FC3test2.
 
--download-only had been mentioned to be present in "upstream yum",
however, it doesn't seem to be mentioned in "man yum" nor yum --help.

So, I might have hit a "known bug" in an "intentionally non-documented
hidden" feature :-)
Comment 1 Ralf Corsepius 2004-09-21 03:47:30 EDT
Of cause, I meant FC3test2, not FC3test3.
Comment 2 Seth Vidal 2004-09-21 09:11:36 EDT
you're right, it's not been implemented yet.

closing this as a duplicate of:
https://devel.linux.duke.edu/bugzilla/show_bug.cgi?id=310

Note You need to log in before you can comment on or make changes to this bug.