Bug 1330529 - [DHT-Rebalance]: with few brick process down, rebalance process isn't killed even after stopping rebalance process
Summary: [DHT-Rebalance]: with few brick process down, rebalance process isn't killed ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.7.11
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On: 1327507
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-26 12:13 UTC by Susant Kumar Palai
Modified: 2016-06-28 12:15 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1327507
Environment:
Last Closed: 2016-06-28 12:15:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-26 12:16:03 UTC
REVIEW: http://review.gluster.org/14076 (dht/rebalance: Handle GF_DEFRAG_STOP) posted (#1) for review on release-3.7 by Susant Palai (spalai@redhat.com)

Comment 2 Susant Kumar Palai 2016-04-26 12:16:58 UTC
http://review.gluster.org/14076

Comment 3 Vijay Bellur 2016-04-26 19:00:29 UTC
REVIEW: http://review.gluster.org/14076 (dht/rebalance: Handle GF_DEFRAG_STOP) posted (#2) for review on release-3.7 by Jeff Darcy (jdarcy@redhat.com)

Comment 4 Vijay Bellur 2016-04-26 19:02:29 UTC
COMMIT: http://review.gluster.org/14076 committed in release-3.7 by Jeff Darcy (jdarcy@redhat.com) 
------
commit 034c986b9b665714aca09e5422bef24466604115
Author: Susant Palai <spalai@redhat.com>
Date:   Fri Apr 15 05:15:33 2016 -0400

    dht/rebalance: Handle GF_DEFRAG_STOP
    
    Backport of http://review.gluster.org/14004
    
    Problem: On a rebal stop, the migrator threads don't intimate the
    crawler thread to wake up in case it is waiting on signal from
    migrator thread.
    
    BUG: 1330529
    Change-Id: I9019a715c7b4673b8bb5a75d7d33a18add85ce33
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/14076
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>

Comment 5 Kaushal 2016-06-28 12:15:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.