Bug 1330552 - [RFE] Don't allow editing NIC configurations if they are unmanaged/NM_CONTROLLED=no
Summary: [RFE] Don't allow editing NIC configurations if they are unmanaged/NM_CONTROL...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: rc
: 7.2
Assignee: Dominik Perpeet
QA Contact: Jan Ščotka
URL: https://github.com/cockpit-project/co...
Whiteboard:
Keywords: Extras, FutureFeature
Depends On:
Blocks: ovirt-node-ng-platform
TreeView+ depends on / blocked
 
Reported: 2016-04-26 12:39 UTC by Fabian Deutsch
Modified: 2016-08-05 09:12 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-08-04 13:47:22 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1442 normal SHIPPED_LIVE cockpit bug fix and enhancement update 2016-08-04 17:45:50 UTC

Description Fabian Deutsch 2016-04-26 12:39:31 UTC
Description of problem:
NICs can be configured to be not managed by NM by adding NM_CONTROLLED=no to the ifcfg-* file.
Those NICs will appear as "unmanaged" in "nmcli d".

Cockpit should prevent that a user can edit these NICs.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Marius Vollmer 2016-04-28 08:52:54 UTC
See https://github.com/cockpit-project/cockpit/issues/1308

Comment 4 Stef Walter 2016-05-25 06:52:54 UTC
Marius, this is an important bug for RHEV-H use of Cockpit. Did you already have a patch for making this work?

Comment 5 Stef Walter 2016-06-23 13:28:06 UTC
Haven't heard from Marius. I think I have a patch.

Comment 7 Stef Walter 2016-06-24 08:15:24 UTC
Will be included in Cockpit upstream 0.112, and included in RHEL during the next update. I'm not updating FixedInVersion or setting MODIFIED until we know that it's inlcuded in a RHEL release.

Comment 9 Stef Walter 2016-07-14 12:22:15 UTC
Cockpit integration test here: https://github.com/cockpit-project/cockpit/blob/master/test/verify/check-networking#L181

Comment 12 errata-xmlrpc 2016-08-04 13:47:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1442.html


Note You need to log in before you can comment on or make changes to this bug.