Bug 1330569 - Calendar view causes display to go black, mouse to become jerky, on startup
Summary: Calendar view causes display to go black, mouse to become jerky, on startup
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-26 13:31 UTC by Robin Green
Modified: 2016-08-23 14:26 UTC (History)
4 users (show)

Fixed In Version: thunderbird-45.1.0-2.fc23 thunderbird-45.1.0-2.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 14:26:17 UTC


Attachments (Terms of Use)

Description Robin Green 2016-04-26 13:31:11 UTC
Description of problem:
After upgrading Thunderbird, Calendar won't load properly, and also renders the whole machine unusably slow until Thunderbird is killed.

Version-Release number of selected component (if applicable):
thunderbird-45.0-2.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start Thunderbird
2. Open Calendar
3. Quit Thunderbird, with Calendar tab still open
4. Start Thunderbird again

Actual results:
Calendar starts to load, then entire display (except for the KDE panel) goes black and the mouse becomes jerky.

Expected results:
Calendar should load normally.

Additional info:
Output on terminal:
○ → thunderbird
[calBackendLoader] Using libical backend at /home/robin/.thunderbird/grcarbgx.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/libical-manifest

(thunderbird:18578): Gtk-WARNING **: Theme directory actions/48 of theme breeze has no size field


(thunderbird:18578): Gtk-WARNING **: Theme directory categories/16 of theme breeze has no size field


(thunderbird:18578): Gtk-WARNING **: Theme directory categories/22 of theme breeze has no size field


(thunderbird:18578): Gtk-WARNING **: Theme directory categories/48 of theme breeze has no size field


(thunderbird:18578): Gtk-WARNING **: Theme directory devices/48 of theme breeze has no size field

TypeError: view is null
-- Exception object --
*
-- Stack Trace --
switchToView@chrome://calendar/content/calendar-views.js:243:1
ltnSwitch2Calendar@chrome://lightning/content/messenger-overlay-sidebar.js:545:5
calendarTabType.modes.calendar.openTab@chrome://lightning/content/messenger-overlay-sidebar.js:49:13
openTab@chrome://messenger/content/tabmail.xml:564:1
calendarTabType.modes.calendar.restoreTab@chrome://lightning/content/messenger-overlay-sidebar.js:76:9
restoreTab@chrome://messenger/content/tabmail.xml:994:11
restoreTabs@chrome://messenger/content/tabmail.xml:1018:18
atStartupRestoreTabs@chrome://messenger/content/msgMail3PaneWindow.js:743:5
loadStartFolder@chrome://messenger/content/msgMail3PaneWindow.js:838:23

Comment 1 Robin Green 2016-05-02 14:58:52 UTC
Interestingly, it is Xorg that uses the most memory (a vast amount) and the most CPU before I kill thunderbird, although thunderbird also uses 30% CPU continuously before I kill it. I suspect that the problem involves some kind of infinite loop that uses more and more memory in X, causing the window manager to malfunction (hence the semi-blank screen?)

Comment 2 Eric Lavarde 2016-05-06 07:35:47 UTC
I can confirm the issue, with a few additional information:
- the problem has appeared very recently, I guess during the last upgrade (the upgrade during the week-end seems too early for me):

Begin time     : Tue May  3 20:08:46 2016
    Upgraded thunderbird-45.0-2.fc23.x86_64                        @updates
    Upgrade              45.0-4.fc23.x86_64                        @updates
    Upgraded thunderbird-lightning-gdata-45.02.6.0.3-2.fc23.x86_64 @updates
    Upgrade                              45.02.6.0.3-4.fc23.x86_64 @updates
Begin time     : Sat Apr 30 09:06:12 2016
    Upgraded   thunderbird-38.7.1-1.fc23.x86_64                         @updates
    Upgrade                45.0-2.fc23.x86_64                           @updates
    Upgraded   thunderbird-lightning-gdata-38.7.11.9.0.3-1.fc23.x86_64  @updates
    Upgrade                                45.02.6.0.3-2.fc23.x86_64    @updates

- probably depending on the computer's power, in my case, the window first grows in the width, probably endlessly, until the window becomes unmanageable by X (then it also becomes black, flickers and the window border disappears)
- the problem appears only if I have the "Events" or the "Tasks" tab open and disappears as soon as I close it (the huge width remains and I need to resize the window)
- meaning it sounds like a Lightning issue, not a pure thunderbird issue (other tabs don't show the same behavior, chat or e-mail).

When I open the Calendar tab, the Error Console shows the following four errors:

Timestamp: 06/05/16 09:30:43
Error: TypeError: currentView(...) is undefined
Source File: chrome://calendar/content/calendar-chrome-startup.js
Line: 90

Timestamp: 06/05/16 09:30:43
Error: view is null
Source File: chrome://calendar/content/calendar-views.js
Line: 243

Timestamp: 06/05/16 09:30:55
Error: TypeError: currentView(...) is undefined
Source File: chrome://calendar/content/calendar-chrome-startup.js
Line: 90

Timestamp: 06/05/16 09:30:55
Error: TypeError: aOldTab._ext.glodaSearchBox is undefined
Source File: chrome://messenger/content/searchBar.js
Line: 58

And the following two errors if I start the tasks tab:

Timestamp: 06/05/16 09:33:13
Error: TypeError: currentView(...) is undefined
Source File: chrome://calendar/content/calendar-chrome-startup.js
Line: 90

Timestamp: 06/05/16 09:33:13
Error: TypeError: currentView(...) is undefined
Source File: chrome://calendar/content/calendar-chrome-startup.js
Line: 90

This issue is important because it makes lightning completely unusable, let me know if I can provide more information to help fix the issue.

Comment 3 Jan Horak 2016-05-17 13:29:29 UTC
Could you tell us which locale are you using? Try to delete localstore.rdf from your profile (usually located in $HOME/.thunderbird/[your_profile]) to reset Thunderbird window sizes.

Feel free to test latest builds from koji if it brings you any relief: http://koji.fedoraproject.org/koji/packageinfo?packageID=39 (currently in progress build thunderbird-45.1.0-1).

Comment 4 Fedora Update System 2016-05-19 06:59:34 UTC
thunderbird-45.1.0-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa576c7699

Comment 5 Fedora Update System 2016-05-19 06:59:47 UTC
thunderbird-45.1.0-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-71d3d705a3

Comment 6 Fedora Update System 2016-05-19 06:59:55 UTC
thunderbird-45.1.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a302f49f6d

Comment 7 Jan Horak 2016-05-19 07:07:49 UTC
I've just made an update which should address your issue. Could you please try it if it fixes your problems? You can use update-testing repository or get builds from koji: http://koji.fedoraproject.org/koji/packageinfo?packageID=39

Comment 8 Fedora Update System 2016-05-21 01:22:59 UTC
thunderbird-45.1.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a302f49f6d

Comment 9 Fedora Update System 2016-05-21 01:33:28 UTC
thunderbird-45.1.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-71d3d705a3

Comment 10 Fedora Update System 2016-05-21 02:27:43 UTC
thunderbird-45.1.0-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa576c7699

Comment 11 Fedora Update System 2016-05-22 02:25:17 UTC
thunderbird-45.1.0-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-05-25 20:03:26 UTC
thunderbird-45.1.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Eric Lavarde 2016-05-29 17:15:43 UTC
Sorry for the delay in answering, was in holiday, but I can now confirm that the bug is fixed with the latest version of Thunderbird on fc23.
Just in case someone hits this: I had the impression that I have needed a full reboot to get the bug to go away, but I might just have forgotten to close a window.

Comment 14 Fedora Update System 2016-06-09 08:49:31 UTC
thunderbird-45.1.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-22cdb97bb4

Comment 15 Fedora Update System 2016-06-10 03:23:53 UTC
thunderbird-45.1.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-22cdb97bb4

Comment 16 Fedora Update System 2016-06-13 13:19:28 UTC
thunderbird-45.1.1-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-babda1429a

Comment 17 Fedora Update System 2016-06-13 22:27:20 UTC
thunderbird-45.1.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-babda1429a

Comment 18 Fedora Update System 2016-07-18 08:09:17 UTC
thunderbird-45.2.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee32318ae1

Comment 19 Fedora Update System 2016-07-18 21:52:28 UTC
thunderbird-45.2.0-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee32318ae1

Comment 20 Jan Horak 2016-08-23 14:26:17 UTC
Unfortunately the update didn't make it to Fedora 22. To fix this issue you need to update to recent Fedora.


Note You need to log in before you can comment on or make changes to this bug.