Bug 133060 - http backend should fall back ot direct internet connection when configured to use auto config url
Summary: http backend should fall back ot direct internet connection when configured t...
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 131589
TreeView+ depends on / blocked
 
Reported: 2004-09-21 12:31 UTC by Mark McLoughlin
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 13:12:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (632 bytes, patch)
2004-09-21 13:05 UTC, Mark McLoughlin
no flags Details | Diff

Description Mark McLoughlin 2004-09-21 12:31:50 UTC
Set the auto proxy config url in Desktop Preferences->Network Proxy
and the http backend will fail to connect to servers even on the local
network since it doesn't support the auto proxy mode.

Should have sensible fallbacks here rather than just failing with
"Host not found".

Comment 1 Mark McLoughlin 2004-09-21 13:05:58 UTC
Created attachment 104064 [details]
patch

Simple fix, but the code really could do with more work than just this

Comment 2 Alexander Larsson 2004-09-21 13:10:40 UTC
patch in upstream cvs.


Note You need to log in before you can comment on or make changes to this bug.