Bug 1330632 - After using edit-node to add a driver, Installing the RHEV-H ISO image fails with "Found more than one kernel version"
Summary: After using edit-node to add a driver, Installing the RHEV-H ISO image fails ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.6.0
Hardware: Unspecified
OS: Linux
urgent
urgent
Target Milestone: ovirt-3.6.7
: ---
Assignee: Douglas Schilling Landgraf
QA Contact: Wei Wang
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-26 15:40 UTC by Gordon Watson
Modified: 2016-08-24 07:57 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-06-29 16:08:31 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1369 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6.7 2016-06-29 19:58:33 UTC
oVirt gerrit 56831 master MERGED install.py: Handle multiple kernels for rebuild initramfs 2016-05-13 21:40 UTC
oVirt gerrit 58711 ovirt-3.6 MERGED install.py: Handle multiple kernels for rebuild initramfs 2016-06-06 19:45 UTC
Red Hat Knowledge Base (Solution) 2294941 None None None 2016-08-24 07:57 UTC

Description Gordon Watson 2016-04-26 15:40:07 UTC
Description of problem:

A customer installs a third-party driver into their RHEV-H ISOs via 'edit-node'. This worked fine up to and including 'rhevh-7.2-20160105.1.el7'. However, with the more recent versions, e.g. 'rhevh-7.2-20160328.0.el7', installation fails with "Found more than one kernel version".


Version-Release number of selected component (if applicable):

RHEV-H 7.2 20160328.0 onwards


How reproducible:

Every time with 'rhevh-7.2-20160328.0.el7' onwards.


Steps to Reproduce:
1. edit-node --install-kmod=<kmod_name>.rpm rhevh-7.2-20160328.0.el7ev.iso
2. Upgrade a host with this ISO image
3. Installation should fail.


Actual results:


Expected results:


Additional info:

Comment 4 Douglas Schilling Landgraf 2016-04-29 14:16:14 UTC
Hi Gordon,

As we discussed over irc, the main issue is that the module provided by HP differs from the kernel we provide in the rhev-h. Instead of doing workarounds or patches for such, the best would have HP providing the kernel modules that matches the RHEV-H OS kernel.

# rpm2cpio kmod-hpvsa-1.2.14-113.rhel7u2.x86_64.rpm | cpio -div
./etc/depmod.d/hpvsa.conf
./lib/modules/3.10.0-327.el7.x86_64
./lib/modules/3.10.0-327.el7.x86_64/extra
./lib/modules/3.10.0-327.el7.x86_64/extra/hpvsa
cpio: ./lib/modules/3.10.0-327.el7.x86_64/extra/hpvsa/hpvsa.ko not created: newer or same age version exists
./lib/modules/3.10.0-327.el7.x86_64/extra/hpvsa/hpvsa.ko
5227 blocks

# mount -o loop rhev-hypervisor7-7.2-20160328.0.iso /mnt/
mount: /dev/loop1 is write-protected, mounting read-only

# grep kernel /mnt/isolinux/manifest-rpm.txt 
kernel-3.10.0-327.10.1.el7.x86_64 (RSA/SHA256, Wed Jan 27 13:34:54 2016, Key ID 199e2f91fd431d51)

Is HP available to talk and request such change?
Moving back to assigned.

Thanks!

Comment 18 Wei Wang 2016-05-06 10:43:23 UTC
RHEV-H QE can reproduce this issue.

Versions:
ovirt-node-tools-3.6.1-9.0.el7ev.noarch
rhevh-7.2-20160328.0.el7ev.iso
kmod-hpvsa-1.2.14-113.rhel7u2.x86_64.rpm

Steps:
1. edit-node --install-kmod=kmod-hpvsa-1.2.14-113.rhel7u2.x86_64.rpm rhevh-7.2-20160328.0.el7ev.iso
2. Upgrade a host with this ISO image
3. Installation failed

Result:
"Exception: RuntimeError('Found more than one kernel version')" is displayed during installation

Comment 21 Fabian Deutsch 2016-06-07 07:13:49 UTC
This patch is affecting the installation and upgrade path, please ensure to check especially both upgrade paths (through Engine and through media).

Comment 22 Wei Wang 2016-06-08 08:28:54 UTC
Versions:
ovirt-node-tools-3.6.1-13.0.el7ev.noarch.rpm
rhev-hypervisor7-7.2-20160606.0.iso
kmod-hpvsa-1.2.14-113.rhel7u2.x86_64.rpm

Steps:
1. edit-node --install-kmod=kmod-hpvsa-1.2.14-113.rhel7u2.x86_64.rpm rhev-hypervisor7-7.2-20160606.0.iso
2. Install a host with an early RHEV-H version
3. a) Install vm with this iso(rhev-hypervisor7-7.2-20160606.0-kmod-hpvsa.iso)
3. b) Upgrade a host with this ISO(rhev-hypervisor7-7.2-20160606.0-kmod-hpvsa.iso) in USB disk
3. c) Upgrade host with this ISO(rhev-hypervisor7-7.2-20160606.0-kmod-hpvsa.iso) through RHEVM


Result:
After step 1: ISO with kmod-hpvsa is created as rhev-hypervisor7-7.2-20160606.0-kmod-hpvsa.iso
After step 3:
a) Install rhev-hypervisor7-7.2-20160606.0-kmod-hpvsa.iso on vm successfully, and login with admin account,check in bash shell
   #rpm -qa|grep kmod-hpvsa
   kmod-hpvsa-1.2.14-113.rhel7u2.x86_64
b), c) Upgrade successfully, login and check in bash shell
   #rpm -qa|grep kmod-hpvsa
   kmod-hpvsa-1.2.14-113.rhel7u2.x86_64

So the bug is verified, I will change the status to VERIFIED.

Comment 25 errata-xmlrpc 2016-06-29 16:08:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1369


Note You need to log in before you can comment on or make changes to this bug.