Bug 133064 - FC3T2 Printer Setup not functioning
FC3T2 Printer Setup not functioning
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-21 09:38 EDT by Gerry Tool
Modified: 2015-01-04 17:09 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 21:23:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File requested by Tim Waugh (851.12 KB, text/plain)
2004-09-27 09:20 EDT, Gerry Tool
no flags Details
File requested by Tim Waugh (525.04 KB, text/plain)
2004-09-27 12:01 EDT, Gerry Tool
no flags Details

  None (edit)
Description Gerry Tool 2004-09-21 09:38:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040904 Firefox/0.9.3

Description of problem:
New install of FC3T2.  Setting up printer same way as it works in FC1,
FC2, FC3T1. 

Networked printer attached to Netgear PS110 print server with
IP=192.168.1.102.  Ping to print server OK. 

Set up using Networked Unix (LPD). Server 192.168.1.102, Printer L1.
Printer is HP Desk Jet 970C. (Same problem with a second printer,
Samsung ML-1750.) 

If I try a test page during setup, all looks ok, but it is never
produced.  I also tried no test page then printing a file from Gedit.
The printer shows up in the Gedit print dialog. 

When I open System Tools > Print Manager, it's dialog opens, showing
an icon for the printer, but a dialog labeled Question also pops up
with "No printers found, Run the Printer configuration tool?"  

If I click OK, the Printer Configuration box opens, and the
Description field contains "Network host '192.168.1.102' is busy,
down, or unreachable, will retry in 30 seconds ..."  However, a ping
works just fine.

If I click on the printer icon in Print Manager, it shows the job in
the queue as printing.

I'm not sure whether this is cups, printman, selinux or some other
component.  I originally had selinux as defaulted at install, but then
added selinux=0 to the kernel line in grub.conf.  Same results both ways.

I can reboot to one of the other partitions listed at the beginning of
this report and printing works just fine with the exact same setup.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Define printer
2.Use Printer
3.
    

Actual Results:  No printed output

Expected Results:  Printed output

Additional info:
Comment 1 Gerry Tool 2004-09-22 09:51:06 EDT
Looking at the localhost:631 interface, the Device URL is the same in
FC3T2 as it is in a working FC3T1 system:
Device URL: lpd://192.168.1.102:515/L1
Comment 2 Tim Waugh 2004-09-27 08:43:30 EDT
Please edit /etc/cups/cupsd.conf (as root) and change the 'LogLevel'
line to read:

LogLevel debug2

Then do this:

service cups stop
  (to stop it)
> /var/log/cups/error_log
  (to truncate the error log file)
service cups start
  (to start it with the new LogLevel setting)

Then submit your job again and attach the resulting
/var/log/cups/error_log file.  Thanks.
Comment 3 Gerry Tool 2004-09-27 09:20:34 EDT
Created attachment 104369 [details]
File requested by Tim Waugh
Comment 4 Gerry Tool 2004-09-27 09:21:44 EDT
I did the above.  Print manager shows the job as:
Unknown gerry 1 158k Mon ...  Printing

Properties in Printer configuration shows:
Network host '192.168.1.102' is busy; will retry in 30 seconds...

I stopped cups again to terminate the log file entries

Will now try to attach the log file
Comment 5 Tim Waugh 2004-09-27 10:30:29 EDT
This is the problem line:

I [27/Sep/2004:08:14:09 -0500] [Job 3] Connecting to 192.168.1.102 on
port 0...

But it seems as though the remote host is an ipp://... URI, not an
lpd://... URI as you said.  Am I looking at the wrong queue?

hpdj970c seems to have an incorrect URI:

DEVICE_URI=ipp://192.168.1.102:L1/printers/queue1

The ':L1' part is meant to be a port number.  Does it work to instead
use this?:

ipp://192.168.1.102/printers/L1
Comment 6 Gerry Tool 2004-09-27 11:14:26 EDT
Sorry for that, Tim.  In my frustration to get it working, I had
redefined the printer as you show above and had forgotten about it.

I now have two printers defined, one hplpd and one, hpipp.  I have
sent a job to each as the lines in error_log show below.

D [27/Sep/2004:10:03:26 -0500] StartJob:
envp[10]="DEVICE_URI=ipp://192.168.1.102/printers/L1"
D [27/Sep/2004:10:05:49 -0500] StartJob:
envp[10]="DEVICE_URI=lpd://192.168.1.102/L1"

Neither job is printing.  Print Manager says each is printing.

Printer Configuration says for hpipp:
Network host '192.168.1.102 is busy; will retry in 30 seconds.

for hplpd:
Unable to connect to printer; will retry in 30 seconds... Connection
timed out.

If I ping the server:
[root@gstpc ~]# ping 192.168.1.102
PING 192.168.1.102 (192.168.1.102) 56(84) bytes of data.
64 bytes from 192.168.1.102: icmp_seq=0 ttl=30 time=3.12 ms
64 bytes from 192.168.1.102: icmp_seq=1 ttl=30 time=3.13 ms
64 bytes from 192.168.1.102: icmp_seq=2 ttl=30 time=3.10 ms
64 bytes from 192.168.1.102: icmp_seq=3 ttl=30 time=3.09 ms
64 bytes from 192.168.1.102: icmp_seq=4 ttl=30 time=3.14 ms

--- 192.168.1.102 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4002ms
rtt min/avg/max/mdev = 3.093/3.119/3.142/0.039 ms, pipe 2

By this time, I wonder if there is a set of packages I could remove
and reinstall for a fresh start at troubleshooting.

Are there any more tests I can do for you?

Printing to the printer with an DEVICE_URI=lpd://192.168.1.102/L1
setup in FC2 works fine.

Comment 7 Tim Waugh 2004-09-27 11:29:08 EDT
I need to see the entire error_log file for a job you submit.  Please
follow the instructions in comment #2 again, now that you have
corrected the URI.

Thanks.
Comment 8 Gerry Tool 2004-09-27 12:01:49 EDT
Created attachment 104379 [details]
File requested by Tim Waugh

I sent one job to the hplpd queue and waited a few minutes, then stopped cups
to allow attaching this file.
Comment 9 Tim Waugh 2004-09-27 12:12:02 EDT
Does 'telnet 192.168.1.102 515' connect?
Comment 10 Gerry Tool 2004-09-27 15:22:08 EDT
No, it does not in FC3T2, but does in FC2.
Comment 11 Tim Waugh 2004-09-28 04:31:30 EDT
Some iptables rule preventing output SYNs or something?  Anyway, not
CUPS problem.

What does 'tcpdump -n host 192.168.1.102' say while you are telnetting?
Comment 12 Gerry Tool 2004-09-28 08:33:13 EDT
I have not made any changes to iptables rules since a fresh install of
FC2T3.  I've just kept it up2date.

Here is the output before I killed it:

[root@gstpc gerry]# /usr/sbin/tcpdump -n host 192.168.1.102
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
07:30:15.584183 IP 192.168.1.102.printer > 192.168.1.100.1023: SP
24842105:24842 105(0) ack 2503960261 win 1024 <mss 1024>
07:30:15.585361 IP 192.168.1.100 > 192.168.1.102: icmp 52: host
192.168.1.100 un reachable - admin prohibited
07:30:16.588761 IP 192.168.1.102.telnet > 192.168.1.100.32800: SP
24896426:24896 426(0) ack 2597373140 win 1024 <mss 1024>
07:30:16.588810 IP 192.168.1.100 > 192.168.1.102: icmp 52: host
192.168.1.100 un reachable - admin prohibited
07:30:19.726331 IP 192.168.1.100.32800 > 192.168.1.102.telnet: S
2597373139:2597 373139(0) win 5840 <mss 1460,sackOK,timestamp
4294876162 0,nop,wscale 2>
07:30:19.730620 IP 192.168.1.102.telnet > 192.168.1.100.32800: . ack 1
win 1024
07:30:19.730672 IP 192.168.1.100 > 192.168.1.102: icmp 48: host
192.168.1.100 un reachable - admin prohibited
07:30:20.582119 arp who-has 192.168.1.102 tell 192.168.1.100
07:30:20.583265 arp reply 192.168.1.102 is-at 00:c0:02:56:70:62
07:30:25.877679 IP 192.168.1.102.netbios-dgm >
192.168.1.255.netbios-dgm: NBT UD P PACKET(138)
07:30:36.687214 IP 192.168.1.102.printer > 192.168.1.100.1023: SP
24842105:24842 105(0) ack 2503960261 win 1024 <mss 1024>
07:30:36.687261 IP 192.168.1.100 > 192.168.1.102: icmp 52: host
192.168.1.100 un reachable - admin prohibited
07:30:37.691614 IP 192.168.1.102.telnet > 192.168.1.100.32800: SP
24896426:24896 426(0) ack 2597373140 win 1024 <mss 1024>
07:30:37.691661 IP 192.168.1.100 > 192.168.1.102: icmp 52: host
192.168.1.100 un reachable - admin prohibited

14 packets captured
14 packets received by filter
0 packets dropped by kernel
[root@gstpc gerry]#
Comment 13 Tim Waugh 2004-09-28 08:38:05 EDT
This is not a problem with 192.168.1.102.  The prohibition originates
from 192.168.1.100.
Comment 14 Gerry Tool 2004-09-28 22:47:08 EDT
I see you have closed this as NOTABUG.  Just to be sure I wasn't
working with a borked system, I did a fresh FC3T2 Personal Desktop
install, and updated to the latest cups, desktop-printing packages. I
then tried to install a networked LPD printer as before.  Same results
as detailed in this bug report history.

This may not be a cups bug, or even a printing system bug, but it is
definitely a bug in some FC3T2 component that is stopping LPD print
server network printing from working.  If this persists, there is no
way I can use FC3.  

I have been using this print setup through all the releases (including
all beta and test releases) of RHL and FC from RHL7.3 through FC3T2. 
I currently have a multi-boot system with FC1, FC2, FC3T1 and FC3T2 on
individual partitions.

The setup is working on FC1 and FC2.  Until the last set of rawhide
updates around 9/20, the release date for FC3T2, it was also working
on FC3T1.  I updated that system just before installing FC3T2, and
paid no attention to it again until I just now checked the printing. 
It does not work now, even though I was using it routinely before 9/20.

Can you suggest any other component that could be blocking this from
working that I can test in some way and report a bug against to get it
working again?

Thanks. Gerry Tool
Comment 15 Tim Waugh 2004-09-29 04:20:18 EDT
Perhaps FC1 or FC2 fetch different IP addresses for that machine?  It
really looks to me like a network problem of some sort, *external* to
that machine.
Comment 16 Tim Waugh 2004-09-29 04:26:28 EDT
Reassigning to kernel, in case it's a network problem *internal* to
that machine.
Comment 17 Gerry Tool 2004-09-29 10:26:40 EDT
Additional info.  Since I have multiple kernels installed in my FC3T1
partition, I tried each of them.  Communication with the print server
works fine up through kernel 2.6.8-1.526, and fails with kernel
2.6.8-1.532 and later.

My FC2 partition which communicates fine with the print server uses
kernel 2.6.8-1.521

My FC3T1 partition is using kernel 2.6.8-1.541

In answer to comment #15, both systems fetch IP address 192.168.1.100
for my computer.  The print server is static at 192.168.1.102.
Comment 18 Tim Waugh 2004-09-29 10:30:14 EDT
Oops, looks like I forgot to actually change the component before
reassigning.  Done.
Comment 19 Gerry Tool 2004-10-13 12:14:57 EDT
I have just downloaded, installed and fully updated FC3T3.  This
problem is still present.  My Netgear print server at 192.168.1.102
cannot be accessed by the printing system or by telnet.  It does
respond to a ping.  This is an important facility that will prevent me
and anyone depending on a networked LPD print server (via CUPS) from
using FC3 when it is released.  This is with kernel 2.6.8-1.607.
Comment 20 bcling 2004-10-14 02:27:25 EDT
Same problem noted with same print server.  Installing the latest FC2
kernel fixes the problem.  Telnet to port 23 works OK (not all that
useful though).
Comment 21 Bill Nottingham 2004-10-20 23:47:30 EDT
OUt of curiosity, if you add 'install ipv6 /bin/true' to
/etc/modprobe.conf, does that help?

(It *shouldn't*, but...)
Comment 22 Gerry Tool 2004-10-21 08:34:14 EDT
Thanks for the reply.

No, that didn't make any difference.  I still can't telnet to the
printer IP address as I can in other systems, and the Printer
Configuration tool says 'Unable to connect to printer; will retry in
30 seconds...; Connection timed out'
Comment 23 Gerry Tool 2004-10-26 08:50:33 EDT
This problem still exists in kernel 640 in FC3 Release Candidate 1,
fresh install.  Exact same symptoms.

It appears that no attention, except a question from Bill Nottingham,
has been payed to this bug since Tim Waugh reassigned it to the kernel.

Anyone depending on a networked LPD print server for printing will not
be able to use FC3 until this is fixed.
Comment 24 Gerry Tool 2004-10-27 00:37:14 EDT
FC3 RC2 kernel 643: still the same.
Comment 25 Dave Jones 2004-10-27 14:38:48 EDT
does setting /proc/sys/net/ipv4/tcp_adv_win_scale to 0 fix this ?

Comment 26 Gerry Tool 2004-10-27 21:14:28 EDT
I would like to try that, but haven't been able to figure out how to
"set" it.  tcp_adv_win_scale is a file that contains a single line
with the value 2. If I try to edit it as root, it won't let me save it.

setting it with 

[root@gstpc-test ipv4]# set tcp_adv_win_scale=0
[root@gstpc-test ipv4]# cat tcp_adv_win_scale
2

obviously does nothing.

What is the protocol necessary to set this?

Thanks.
Comment 27 Bill Nottingham 2004-10-27 22:51:23 EDT
echo 0 > /proc/sys/net/ipv4/tcp_adv_win_scale
Comment 28 Gerry Tool 2004-10-27 23:35:47 EDT
I executed the command and the situation did not change.  The print
server could not be accessed by the Printer Configuration tool, and I
could not telnet to the server.  Restarting cups did nothing.  I
rebooted and after reboot, the value is back to 2.  Is there any other
action I should have taken to test the result?
Comment 29 Gerry Tool 2004-10-29 20:16:00 EDT
Just did a fresh install of FC3 Release Candidate 3.  Problem is still
there.  This is still kernel 643.
Comment 30 Gerry Tool 2004-10-30 09:49:11 EDT
Fresh install of Release Candidate 5 - problem is still there.  A list
member sent me the following off list.

"Saw your posting on trouble with fc3 and print server.  I had a similar 
problem with recent kernels.  The problem, as well as I can determine, is 
that iptables behaves differently under the more recent kernels.  Certain 
communications with the print server do not get recognized as established 
connections and are then rejected by the nominal iptables firewall 
configuration.  (They seem to hang as half-open connections.)

What I did to work around this problem is create a rule specifically
allowing 
incoming traffic from the print server and the ipp port number.  Then all 
works fine.

BTW, I tried the recent fc3 kernels on an FC2 install and encountered
the same 
problem with iptables.  All works fine with kernel 521, but have this
problem 
with later kernels.  So it would seem not to be CUPS, but something in
the 
kernel."

Is this of any help.  I do not know how to make the changes he
suggests and have asked him in a reply if he can tell me what to do.

If you know what to do, I will be anxious to try whatever you suggest.
Comment 31 Gerry Tool 2004-10-30 14:16:52 EDT
Thanks to help from Steven Schwartz, I found a key to getting it to work.

If I execute 

/sbin/service iptables off

printing works.  Of course this is not a valid fix for the problem,
but might be a significant clue for finding a real fix.

Comment 32 Gerry Tool 2004-10-30 15:42:13 EDT
Steven Scwartz came up with a change to /etc/sysconfig/iptables that
allows my print server to work.

I added 

-A RH-Firewall-1-INPUT -p tcp -s 192.168.1.102 --sport 515 -j ACCEPT

as the third to last line in this file.

I hope this is useful in solving this problem for all users.  FC3
should ship with networked print servers working "out of the box."
Comment 33 Gerry Tool 2004-10-31 21:26:55 EST
Trying to understand selinux/iptables, I stumbled on something that
may be the key to why networked LPD printing stopped working for me. 
I ran system-config-securitylevel and discovered on the Firewall
Options tab a section labeled Trusted devices.  eth0 was not checked.
 Former installs had a checkbox for selecting eth0 as a trusted
device, and I always checked it since I wanted unfettered
communication on my LAN which is isolated from the internet by a
firewall (hardware router.)  I think this option is no longer offered
by anaconda, but am not sure.

At any rate, I selected eth0 as a trusted device.  I then looked in
/etc/sysconfig/iptables and found that my added line noted in comment
32 was no longer there, but a new line
-A RH-Firewall-1-INPUT -i eth0 -j ACCEPT
was added, and printing now works without my modification to the file.

So, this may just be a problem with changes in installation
configuration where users that previously enabled eth0 as a trusted
device no longer have an installation-time choice to do that.  They
somehow need to be told to manually change this setting in
system-config-securitylevel or to add a specific ACCEPT line for the
print server to the iptables file.

I hope this is clear enough for you to decide how to best handle this
for users that will have the same problem I did.
Comment 34 Mustafa Jamil 2004-11-19 16:31:46 EST
Gerry,

While it may be OK for you to have eth0 as a trusted device, I believe
you're in a minority.  The vast majority of the population would
prefer all external netdevs to default to a safe state.  It's easy for
you to override that, as you found out, but this way, crackers would
have a tough time attacking a default configuration.

I liked your original idea.  IMHO, printconf-gui (and its equivalents)
should silently add the rule you mentioned:

-A RH-Firewall-1-INPUT -p tcp -s <printer-IP> --sport 515 -j ACCEPT

if you specify a networked printer and iptables is active, and
modify/remove this rule if the printer is modified/deleted.  Since
printer configuration requires root privileges, this won't cause any
permissions problem.


Comment 35 Michael J. Chudobiak 2004-12-03 15:14:21 EST
This appears to be a special feature of the Netgear PS110. I ran into
the same problems (except I was using Guarddog to set the iptables
firewall, rather than system-config-securitylevel). I replaced my
Netgear PS110's with Hawking HPS12U's, and everything worked properly
(using LPR). For some reason, the PS110 initiates connections from
port 515, which is unusual.
Comment 36 Marc Bessière 2004-12-19 08:26:53 EST
I'm using a TRENDnet TE100-P1P Print Server and got the same issue
trying to pring via CUPS.

The automatically generated "-A RH-Firewall-1-INPUT -p udp -m udp
--dport 631 -j ACCEPT" firewall rule is not sufficient to get it work.

Manually adding "-A RH-Firewall-1-INPUT -p tcp -s <printer-IP> --sport
631 -j ACCEPT" to "/etc/sysconfig/iptables" was necessary for me.

Hope this helps.
Comment 37 Dave Jones 2005-07-15 15:22:51 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 38 Gerry Tool 2005-07-15 21:23:47 EDT
I am at FC4, and this problem has evidently been cured. I can print to a
networked LPD printer with the firewall enabled or disabled without doing
anything special with iptables.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.