Bug 133067 - smbtree just aborts
smbtree just aborts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-21 10:16 EDT by Havoc Pennington
Modified: 2014-08-31 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 11:20:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2004-09-21 10:16:41 EDT
$ smbtree
Aborted
$

That about covers it ;-)
Comment 1 Havoc Pennington 2004-09-21 10:19:37 EDT
samba-client-3.0.7-3
Comment 3 Bill Nottingham 2004-09-22 15:42:37 EDT
glibc started detection memory corruption, which is why you probably
wouldn't see it on other releases. fclose() on a bad FILE*?
Comment 5 Havoc Pennington 2004-09-22 18:33:09 EDT
fwiw:

#0  0x007ea782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0025e4a5 in raise () from /lib/tls/libc.so.6
#2  0x0025feb9 in abort () from /lib/tls/libc.so.6
#3  0x00296ccb in malloc_printerr () from /lib/tls/libc.so.6
#4  0x00297705 in free () from /lib/tls/libc.so.6
#5  0x00abed46 in x_fclose (f=0xb3fe00) at lib/xfile.c:138
#6  0x00ab43a3 in setup_logging (pname=0xfef0aa68 "/usr/bin/smbtree",
    interactive=1) at lib/debug.c:528
#7  0x00aa797f in main (argc=0, argv=0xfee7a204) at utils/smbtree.c:211

(gdb) frame 6
#6  0x00ab43a3 in setup_logging (pname=0xfef0aa68 "/usr/bin/smbtree",
    interactive=1) at lib/debug.c:528
528                     (void) x_fclose(dbf);
(gdb) p dbf
$1 = (XFILE *) 0xb3fe00
(gdb) p *dbf
$2 = {fd = -1, buf = 0x0, next = 0x0, bufsize = 0, bufused = 0,
  open_flags = 1, buftype = 2, flags = 0}

(gdb) list
523             /* reset to allow multiple setup calls, going from
interactive to
524                non-interactive */
525             stdout_logging = False;
526             if (dbf) {
527                     x_fflush(dbf);
528                     (void) x_fclose(dbf);
529             }
530
531             dbf = NULL;
532


Comment 6 Havoc Pennington 2004-09-22 18:38:08 EDT
[hp@localhost ~]$ valgrind --tool=memcheck smbtree
==23495== Memcheck, a memory error detector for x86-linux.
==23495== Copyright (C) 2002-2004, and GNU GPL'd, by Julian Seward et al.
==23495== Using valgrind-2.2.0, a program supervision framework for
x86-linux.
==23495== Copyright (C) 2000-2004, and GNU GPL'd, by Julian Seward et al.
==23495== For more details, rerun with: -v
==23495==
==23495== Invalid free() / delete / delete[]
==23495==    at 0x1B902FB1: free (vg_replace_malloc.c:153)
==23495==    by 0x2FD45: x_fclose (xfile.c:138)
==23495==    by 0x253A2: setup_logging (debug.c:528)
==23495==    by 0x1897E: main (smbtree.c:211)
==23495==  Address 0xB0E00 is not stack'd, malloc'd or (recently) free'd
Password:
==23495==
==23495== ERROR SUMMARY: 1 errors from 1 contexts (suppressed: 29 from 1)
==23495== malloc/free: in use at exit: 667104 bytes in 438 blocks.
==23495== malloc/free: 871 allocs, 434 frees, 1371991 bytes allocated.
==23495== For a detailed leak analysis,  rerun with: --leak-check=yes
==23495== For counts of detected errors, rerun with: -v
Comment 7 Tim Waugh 2004-10-11 08:54:22 EDT
Looks like this has been fixed in 3.0.8-0.pre1:

revision 1.1
date: 2004/09/29 16:42:13;  author: fenlason;  state: Exp;
Upgrade to 3.0.8pre1
Include a patch to fix #133067
Comment 8 Jay Fenlason 2005-10-24 11:20:31 EDT
Fixed a long time ago afaict. 

Note You need to log in before you can comment on or make changes to this bug.