Bug 133068 - can't login to aim after up2date of gaim
can't login to aim after up2date of gaim
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gaim (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-21 10:18 EDT by Bryan Che
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-06 17:03:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Che 2004-09-21 10:18:21 EDT
Description of problem:

I did an up2date of gaim, and now I can't login to aim.  I get the
message: "bryanc5203 has been disconnected.  Incorrect nickname or
password."  I verified that the name and password are correct.  I am
trying to connect using the default settings for the AIM/ICQ protocol.
 This all worked before doing an up2date of gaim.  I tried rolling
back to an earlier version of gaim, but now I get the same error with
that.  I also tried installing gaim 1.0 from gaim.sourceforge.net, but
I get the same error with that as well.  I was logged into aim fine
just before I closed gaim and did an up2date.


Version-Release number of selected component (if applicable):

gaim-0.82-1-0.RHEL3.i386


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Warren Togami 2004-09-25 23:53:26 EDT
Are you using some proxy or socks?
Comment 2 Warren Togami 2004-10-31 04:03:46 EST
Also try wiping out ~/.gaim and starting with a new profile.  Any
better behavior?
Comment 3 Bryan Che 2004-11-01 17:32:07 EST
It turns out that the newer versions of gaim dropped the TOC protcol,
which I had been using for logging into AIM, and switched me to use
AIM's own protocol.  However, I am unable to login to AIM using that
protocol for some reason.  Downgrading Gaim and reverting to TOC made
things work again.  So, either adding support for TOC or fixing the
AIM/Oscor protocol would resolve this bug.
Comment 4 Warren Togami 2004-11-01 17:37:04 EST
Are you behind a pool NAT where every outgoing connection appears to
come from a different IP address by chance?

Is official Windows AIM broken in the same way?
Comment 5 Bryan Che 2004-11-01 17:42:39 EST
I don't think I'm behind a pool NAT.  I can login to AIM fine with
AOL's own Linux AIM client and also the Windows AIM client.
Comment 7 Daniel Reed 2004-11-01 18:06:47 EST
I am able to sign on to AIM with both TOC (in naim) and OSCAR (in gaim) from the
Westford (Boston) office.
Comment 8 Daniel Reed 2004-11-06 17:03:28 EST
I installed gaim-0.82-1-0.RHEL3.ia64 out of 3.0E-errata on diablo.lab.boston and
was able to sign on using the AIM/ICQ (OSCAR) driver. The latest version in
3.0E-errata is a 1.0, so it appears this version may be outdated anyway.

Note You need to log in before you can comment on or make changes to this bug.