Bug 1330777 - rgw: zone configuration doesn't upgrade (from pre 2.0) if default zone was used
Summary: rgw: zone configuration doesn't upgrade (from pre 2.0) if default zone was used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 2.0
Assignee: Yehuda Sadeh
QA Contact: shilpa
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-26 23:23 UTC by Yehuda Sadeh
Modified: 2017-07-30 15:45 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-10.2.1-1.el7cp Ubuntu: ceph_10.2.1-2redhat1xenial
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:37:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 15597 None None None 2016-04-26 23:26:44 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Yehuda Sadeh 2016-04-26 23:23:01 UTC
Description of problem:

When upgrading from a pre-2.0 rgw, if previously the default zone was used, we cannot access the users and data (without re-configuring the system).


Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. configure ceph (rgw) version 1.3.2, don't configure zone, use default config
2. create user + buckets
3. upgrade to 2.0
4. restart rgw
5. try to access user's data


Actual results:

Cannot access user's data. New pools were created on the backing ceph cluster with a new default configuration. Need to then reconfigure manually with old pools.

Expected results:
Need to still access existing data.

Additional info:

Comment 2 Yehuda Sadeh 2016-05-06 22:17:26 UTC
upstream PR:
https://github.com/ceph/ceph/pull/8766

Comment 3 Ken Dreyer (Red Hat) 2016-05-10 02:42:55 UTC
The PR Yehuda mentioned in Comment 2 has been merged to master. We still need the changes to be backported to jewel.

Comment 4 Ken Dreyer (Red Hat) 2016-05-10 13:08:59 UTC
Cherry-pick to jewel in progress: 
https://github.com/ceph/ceph/pull/9020

Comment 5 Ken Dreyer (Red Hat) 2016-05-16 15:30:32 UTC
The above PR was merged to jewel and is present in v10.2.1.

Comment 8 shilpa 2016-07-28 16:46:00 UTC
Moving to verified based on BZ:1352888

Comment 10 errata-xmlrpc 2016-08-23 19:37:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.