Bug 1330843 - 'man ipa' should be updated with latest commands
Summary: 'man ipa' should be updated with latest commands
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-27 06:41 UTC by Sudhir Menon
Modified: 2016-11-04 05:53 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:53:34 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-04-27 06:41:51 UTC
Description of problem:'man ipa' should be updated with latest commands

Version-Release number of selected component (if applicable):

How reproducible: Always


Steps to Reproduce:
1. On RHEL7.2 ipa setup, run 'man ipa'

Actual results:

1. ipa user-find --uuid 936407bd-da9b-11de-9abd-54520012e7cd

[root@host2 ~]#  ipa user-find --uuid 936407bd-da9b-11de-9abd-54520012e7cd
Usage: ipa [global-options] user-find [CRITERIA] [options]
ipa: error: no such option: --uuid

2. ipa-upgradeconfig
[root@host2 ~]# ipa-upgradeconfig 
Please run the 'ipa-server-upgrade' command to upgrade the IPA server.

3. ipa-host-net-manage
[root@host2 ~]# ipa-host-net-manage
bash: ipa-host-net-manage: command not found...

Expected results:
The man page should be updated and refer to latest/supported commands for the specific release rather than deprecated commands.

Update the SEE ALSO section

SEE ALSO
ipa-client-install(1), ipa-compat-manage(1), ipactl(1), ipa-dns-install(1), ipa-getcert(1), ipa-getkeytab(1), ipa-join(1), ipa-ldap-updater(1), ipa-nis-manage(1), ipa-replica-install(1), ipa-replica-manage(1), ipa-replica-prepare(1), ipa-rmkeytab(1),ipa-server-certinstall(2), ipa-server-install(1), ipa-upgradeconfig(1), ipa-host-net-manage(1)

Additional info: man ipa

Comment 2 Petr Vobornik 2016-05-03 15:27:35 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5871

Comment 5 Abhijeet Kasurde 2016-07-13 04:03:45 UTC
IPA Version used to verify ::
ipa-server-4.4.0-1.el7.x86_64

Steps involved in verification ::

[root@server1 ~]# man ipa | grep 2016
IPA                                                 Apr 29 2016                                              ipa(1)
[root@server1 ~]# man ipa | grep uuid
[root@server1 ~]# echo $? 
1
[root@server1 ~]# man ipa |grep host-net-manage
[root@server1 ~]# echo $? 
1
[root@server1 ~]# rpm -q ipa-server
ipa-server-4.4.0-1.el7.x86_64


Man page reflects updates, hence marking bz as verified.

Comment 7 errata-xmlrpc 2016-11-04 05:53:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.