Bug 1330892 - nfs-ganesha crashes with segfault error while doing refresh config on volume.
Summary: nfs-ganesha crashes with segfault error while doing refresh config on volume.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ganesha-nfs
Version: 3.7.11
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1325975 1326627
TreeView+ depends on / blocked
 
Reported: 2016-04-27 09:11 UTC by Soumya Koduri
Modified: 2016-06-28 12:15 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Clone Of: 1326627
Environment:
Last Closed: 2016-06-28 12:15:37 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-04-27 09:12:29 UTC
REVIEW: http://review.gluster.org/14089 (inode: Always fetch first entry from the inode lists during inode_table_destroy) posted (#1) for review on release-3.7 by soumya k (skoduri@redhat.com)

Comment 2 Vijay Bellur 2016-04-28 06:06:13 UTC
REVIEW: http://review.gluster.org/14089 (inode: Always fetch first entry from the inode lists during inode_table_destroy) posted (#2) for review on release-3.7 by soumya k (skoduri@redhat.com)

Comment 3 Vijay Bellur 2016-04-28 10:40:12 UTC
REVIEW: http://review.gluster.org/14089 (inode: Always fetch first entry from the inode lists during inode_table_destroy) posted (#3) for review on release-3.7 by soumya k (skoduri@redhat.com)

Comment 4 Vijay Bellur 2016-04-29 09:06:27 UTC
COMMIT: http://review.gluster.org/14089 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit c8e5d078ce8b02f1ce0a4692a1170cd760fbb260
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Wed Apr 13 12:50:49 2016 +0530

    inode: Always fetch first entry from the inode lists during inode_table_destroy
    
    In inode_table_destroy, we iterate through lru and active lists
    to move the entries to purge list so that they can be destroyed
    during inode_table_prune.
    
    But if used "list_for_each_entry" or "list_for_each_entry_safe"
    to iterate, we could end up accessing the entries which may have
    got moved to different(purge) lists in the process and can result
    in either infinite loop or crash. The safe approach seems to fetch
    the first entry of the list in each iteration till it gets empty.
    
    This is backport of below mainline fix -
            http://review.gluster.org/13987
    
    Change-Id: I24a18881833bd9419c2d8e5e8807bc71ec396479
    BUG: 1330892
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13987
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-on: http://review.gluster.org/14089
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 5 Kaushal 2016-06-28 12:15:37 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.