Bug 133097 - kernel module api changed after 2.6.8-1.579
kernel module api changed after 2.6.8-1.579
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-21 14:07 EDT by John Ellson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 15:14:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2004-09-21 14:07:20 EDT
Description of problem:
In kernels after 2.6.8-1.579 the symbol __VMALLOC_RESERVE
is not exported, breaking certain externally built modules.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.8-1.584

How reproducible:
100% since 2.6.8-1.579

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Breaks external modules

Expected results:
No non-backward compatible module API changes without reasonable notice.

Additional info:
The following thread includes a one line patch to re-export the
symbol.
http://www.nvnews.net/vbulletin/showthread.php?t=37112
Comment 1 Arjan van de Ven 2004-09-21 14:08:24 EDT
modules have no business using this deep internal info.
Comment 2 John Ellson 2004-09-21 14:28:51 EDT
So you file a bug with NVIDIA !   Presumably you can point them at the
complete and accurate documentation of which symbols they are allowed
to use.

Since a one line, zero cost, fix is known for this why are you
insisting on causing so many Fedora users so much grief?






Comment 3 Mike A. Harris 2004-09-21 15:14:54 EDT
Please report this problem to Nvidia via their customer
technical support, and they will likely address the issue in a
future driver update.  Nvidia might not officially support
Fedora Core 3 test2 at this juncture, however once Fedora Core 3
is officially released, they will probably release a new driver
which supports the final OS release.

Thanks for reporting this problem to Nvidia.

Note You need to log in before you can comment on or make changes to this bug.