Bug 1330974 - Swap order of GF_EVENT_SOME_CHILD_DOWN enum to match the release3.-7 branch
Summary: Swap order of GF_EVENT_SOME_CHILD_DOWN enum to match the release3.-7 branch
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-27 11:40 UTC by Ravishankar N
Modified: 2016-06-16 14:04 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-16 14:04:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2016-04-27 11:40:39 UTC
Description of problem:

GF_EVENT_SOME_CHILD_DOWN value seems to be mismatching between master and 3.7. Fix the master since 3.7 is a release branch and GF_EVENT_SOME_CHILD_DOWN was added newly and hence should be in the end in the enum list.

Comment 1 Vijay Bellur 2016-04-27 11:42:43 UTC
REVIEW: http://review.gluster.org/14092 (Swap order of GF_EVENT_SOME_CHILD_DOWN enum) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 2 Vijay Bellur 2016-04-28 04:20:09 UTC
COMMIT: http://review.gluster.org/14092 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 1890e5e09203e65b1c64f0f13c213d8944b81b87
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed Apr 27 11:41:05 2016 +0000

    Swap order of GF_EVENT_SOME_CHILD_DOWN enum
    
    GF_EVENT_SOME_CHILD_DOWN value seems to be mismatching between master and 3.7.
    Fix the master since 3.7 is a release branch and GF_EVENT_SOME_CHILD_DOWN was
    added newly and hence should be in the end in the enum list.
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    
    Change-Id: I1f758550d6300f6750d1574302096d8e7f493549
    BUG: 1330974
    Reviewed-on: http://review.gluster.org/14092
    Tested-by: Ravishankar N <ravishankar@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 3 Niels de Vos 2016-06-16 14:04:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.