Bug 133105 - apm/power-management broken on Thinkpad 600E
apm/power-management broken on Thinkpad 600E
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-21 14:27 EDT by Satish Balay
Modified: 2015-01-04 17:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 14:18:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (23.24 KB, text/plain)
2004-09-21 14:29 EDT, Satish Balay
no flags Details

  None (edit)
Description Satish Balay 2004-09-21 14:27:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040916

Description of problem:
APM does not work on a thinkpad 600E
- Suspend doesn't work (Fn-F4 or apm -s)
- battery meter doesn't work (apm)
- shutdown goes all the way - but doesn't power off

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1. Install FC2T3 (selinux disabled)
2. boot (perhaps to gnome)
3. try suspend with keystrokes 'Fn-F4'
5. try suspend with command (as root)'apm -s'
6. try battery status with command 'apm'
6. try shutdown with 'shutdown -h'
    

Actual Results:  1. Fn-F4 does nothing

2. 
[root@localhost balay]# apm -s
apm: Input/output error

With the following in /var/log/messages
Sep 21 13:03:11 localhost network: Shutting down loopback interface: 
succeeded
Sep 21 13:03:12 localhost apmd[1925]: User Suspend
Sep 21 13:03:15 localhost kernel: psmouse.c: Mouse at
isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
Sep 21 13:03:15 localhost kernel: apm: suspend: No APM present
Sep 21 13:03:19 localhost kernel: Disabled Privacy Extensions on
device 02359760(lo)
Sep 21 13:03:20 localhost netfs: Mounting other filesystems:  succeeded
Sep 21 13:03:20 localhost netfs: Mounting other filesystems:  succeeded
Sep 21 13:03:20 localhost apmd[1925]: Normal Resume after 00:00:08
(-1% unknown) ??? power
----

3. 'apm' (battery status) shows nothing
[root@localhost balay]# apm

[root@localhost balay]#


Expected Results:  
Proper suspend/ battery status/ shutdown function

Additional info:

Current rawhide kernel-2.6.8-1.584 also has this problem

dmesg |grep -i apm
IBM machine detected. Enabling interrupts during APM calls.
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: driver version: No APM present
apm: get_event: No APM present
apm_do_idle failed (134)
apm_do_idle failed (134)
[balay@localhost ~]$ /sbin/lspci 
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host
bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge
(rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1251A
00:02.1 CardBus bridge: Texas Instruments PCI1251A
00:06.0 Multimedia audio controller: Cirrus Logic CS 4610/11
[CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
01:00.0 VGA compatible controller: Neomagic Corporation NM2200
[MagicGraph 256AV] (rev 12)
[balay@localhost ~]$
Comment 1 Satish Balay 2004-09-21 14:29:19 EDT
Created attachment 104083 [details]
/var/log/messages
Comment 2 Satish Balay 2004-09-21 14:38:48 EDT
'shutdown -h now' gives a bunch of messages - and stops at:

Shutdown: hda
Powerdown

- At this time - I have to give a hard reset (toggle the power switch
for 5/10 seconds until the laptop powers off)
Comment 3 Bill Nottingham 2004-09-22 15:50:29 EDT
I'm assuming you did boot with acpi=off, yes?
Comment 4 Satish Balay 2004-09-22 16:19:18 EDT
I hadn't as it gets automatically disabled. From the log:

Sep 21 11:43:38 localhost kernel: ACPI disabled because your bios is
from 1999 and too old

I've tried again with 'acpi=off apm=on' with the same behavior

Comment 5 Satish Balay 2004-09-22 16:29:27 EDT
I've had ACPI & APM problems with ThinkPad T40 as well. The ACPI
issues are filed at 

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=133176

I thought I filed the APM issue with the T40 here - I guess I must
have goofed it up (so I don't have all the info now)

Summary: APM doesn't work on a T40 as well. The behavior is slightly
different.
 - FN-F4 doesn't do anything.
 - "apm" prints the battery status - but it doesn't know if AC is
connected or not.
 - 'apm -s' sends it to suspend - but on attempting to recover back -
it just hangs. The screen is still blank, the suspend indicator LED is
on (the moon cresent) - but the CPU fan starts spinning - and the
CDROM lights up. I have to power cycle for 5/10 sec  and shutdown the
machine to get out of this hang
 
Comment 6 Jason 'vanRijn' Kasper 2004-09-24 19:29:11 EDT
this happens for me too.  I have an IBM A31 laptop.  Using "apm -s",
the laptop seems to power down perfectly.  But when I lift the lid,
where before (with FC2 and anything previous to that) the laptop would
resume, now (using FC3T2), the laptop does not resume.  The moon
(sleeping) light stays lit, and nothing short of powering the laptop
down (holding the power button for 5+ seconds) will work.
Comment 7 Ed Hill 2004-10-12 07:02:34 EDT
OK, I haven't installed any FC3 Test releases but I did have trouble
with apm and acpi on my ThinkPad A22p with FC2 and the eventual
solution was:

 1) boot with "acpi=off"
 2) then issue:
     $ /sbin/cardctl eject ; /etc/init.d/pcmcia stop
     $ /sbin/rmmod ds ; /sbin/rmmod yenta_socket
     $ /sbin/rmmod pcmcia_core
 3) after all pcmcia is unloaded, then APM suspend and resume worked

Does this help anyone here?  I really don't want to install FC3 if APM
is going to fail.
Comment 8 Satish Balay 2004-10-12 10:30:59 EDT
#7, APM with FC2 worked fine (as far as I can remember). I think the
breakage happened sometime between FC3T1 & FC3T2
Comment 9 Satish Balay 2004-10-13 09:56:50 EDT
I tried the 607 kernel on IBM T40. APM appears to work now.

- Fn-F4 sends it to suspend
- Fn key appears to recover from suspend correctly
- APM knows when AC is disconnected.

Comment 10 Satish Balay 2004-10-13 12:37:05 EDT
The 607 kernel also fixes the 600E problems. Fn-F4 brings it into
suspend - and the other things also work.

This issue can be closed now.
Comment 11 Dave Jones 2005-07-15 14:06:29 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 12 Satish Balay 2005-07-15 14:11:51 EDT
The last kernel I ran on this machine was the FC4 [release?] version - and it
[APM} suspended fine. I don't have FC3 anymore on it to verify.
Comment 13 Dave Jones 2005-07-15 14:18:51 EDT
Ok, the two kernels of FC3 and FC4 are now in sync anyway, so chances are this
is also fixed for FC3.

Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.