Bug 1331093 - SCVMM Provider refresh error refresh_parser.rb:324:in `process_snapshots'
Summary: SCVMM Provider refresh error refresh_parser.rb:324:in `process_snapshots'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.5.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.5.5
Assignee: Bronagh Sorota
QA Contact: Jeff Teehan
URL:
Whiteboard: scvmm:ems_refresh:snapshot:retest
Depends On: 1298325
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-27 17:28 UTC by John Prause
Modified: 2019-11-14 07:52 UTC (History)
11 users (show)

Fixed In Version: 5.5.5.2
Doc Type: Bug Fix
Doc Text:
Previously in some CloudForms environments, refreshing a SCVMM provider resulted in an error reporting "undefined method `each' for nil:NilClass". This was caused by an issue with snapshot processing. The refresh_parser code has been updated and now returns an empty array if the VMCheckpoints value is nil, rather than returning an error.
Clone Of: 1298325
Environment:
Last Closed: 2016-07-26 15:33:14 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Comment 2 CFME Bot 2016-06-23 18:38:21 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2afa4c0c35c9c85737d67f1968d76a4a9a9929a8

commit 2afa4c0c35c9c85737d67f1968d76a4a9a9929a8
Author:     Bronagh Sorota <bsorota@redhat.com>
AuthorDate: Tue Apr 26 13:51:32 2016 -0400
Commit:     Bronagh Sorota <bsorota@redhat.com>
CommitDate: Mon Jun 13 12:47:58 2016 -0400

    Return empty array if VMCheckpoints is NIL.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1331093
    
    Clean cherrypick
    
    Upstream PR: https://github.com/ManageIQ/manageiq/pull/8259
    Upstream BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1298325

 .../manageiq/providers/microsoft/infra_manager/refresh_parser.rb    | 6 ++++++
 1 file changed, 6 insertions(+)

Comment 3 CFME Bot 2016-06-23 18:38:26 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=994a9356b8ebee33347c39d308c372808994880b

commit 994a9356b8ebee33347c39d308c372808994880b
Merge: 7a4e9d4 2afa4c0
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Thu Jun 23 14:33:48 2016 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Thu Jun 23 14:33:48 2016 -0400

    Merge branch 'scvmm_snapshot_exception_5.5.z' into '5.5.z'
    
    SCVMM - Return empty array if VMCheckpoints is NIL.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1331093
    
    Clean cherrypick
    
    Upstream PR: https://github.com/ManageIQ/manageiq/pull/8259
    Upstream BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1298325
    
    See merge request !963

 .../manageiq/providers/microsoft/infra_manager/refresh_parser.rb    | 6 ++++++
 1 file changed, 6 insertions(+)

Comment 5 Jeff Teehan 2016-07-14 23:40:57 UTC
Since I never could reproduce this, I just walked through the code like I did for 5.6.  That change has been in for a while and there haven't been any unintended consequences.  The change inserts an empty set rather than nil.  I'm going to move it to verified.

Comment 7 errata-xmlrpc 2016-07-26 15:33:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.