Bug 133128 - Not enough ttys
Not enough ttys
Status: CLOSED DUPLICATE of bug 128154
Product: Fedora
Classification: Fedora
Component: MAKEDEV (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-21 15:50 EDT by awm
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 20:36:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description awm 2004-09-21 15:50:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10

Description of problem:
There seems to be either a shortage of ttys or somehow ssh/xterms are
not able to open the next tty. 

Opening a new xterm or ssh session after the first couple results in
disconnection or the following message: 

Warning: no access to tty (Bad file descriptor).
                                                Thus no job control in
this shell.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open four ssh or xterms
2.Try to open a 5th session

    

Actual Results:  Warning: no access to tty (Bad file descriptor).
                                                Thus no job control in
this shell.

And you are hung. 
I have tried it both locally and remotely.

Expected Results:  You should get a shell prompt

Additional info:
Comment 1 Bill Nottingham 2004-09-22 15:51:36 EDT
What kernel? Are you using udev?
Comment 2 Aram Mirzadeh 2004-09-23 07:54:21 EDT
Using:

Linux tigger 2.6.7-1.478smp #1 SMP Thu Jul 8 15:17:25 EDT 2004 i686
i686 i386 GNU/Linux

I just downloaded 2.6.8-1.541 and am going to give it a try.

udev is installed and USE_UDEV is set to yes, however I have not made
any changes to it from the test3 release.
Comment 3 Florian La Roche 2004-09-26 05:19:35 EDT
Is this xterm, gnome-terminal or konsole you are seeing this error
with? Please also specify the exact rpm version number you use.

Thanks,

Florian La Roche
Comment 4 Aram Mirzadeh 2004-09-26 17:22:08 EDT
It isn't limited to local X11 sessions.  SSH from external sources end
up with the same error.

Using 'telnet localhost' will result in: 

Trying 127.0.0.1 ...
Connected to localhost.
Escape chracter is '^]'.
telnetd: All network ports in use.
Connection closed  by foreign host.

# ssh localhost 
awm@localhost's password: 
Warning: no access to tty (Bad file descriptor). 
                                                 Thus no job control
in this shell.


And hangs the session.
Comment 5 Aram Mirzadeh 2004-09-26 17:24:55 EDT
More notes, this must be a 'leak' of some type.  After a reboot I can
open 30+ sessions just via xterm, after the system has been up for a
while ( in this case 3 days 9 hours ) I can only open more sessions if
I  close out some of the old ones.
Comment 6 Nalin Dahyabhai 2004-09-28 11:43:20 EDT
This looks like a duplicate of bug #128154.
Comment 7 Aram Mirzadeh 2004-09-30 09:09:34 EDT
Agreed.
Comment 8 Nalin Dahyabhai 2004-11-01 20:36:31 EST

*** This bug has been marked as a duplicate of 128154 ***

Note You need to log in before you can comment on or make changes to this bug.