Bug 1331287 - No xml output on gluster volume heal info command with --xml
Summary: No xml output on gluster volume heal info command with --xml
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: All
OS: Linux
high
low
Target Milestone: ---
Assignee: hari gowtham
QA Contact:
URL:
Whiteboard:
Depends On: 1063506 1334074
Blocks: 1313370
TreeView+ depends on / blocked
 
Reported: 2016-04-28 08:21 UTC by hari gowtham
Modified: 2017-03-27 18:21 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1063506
Environment:
Last Closed: 2017-03-27 18:21:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description hari gowtham 2016-04-28 08:21:15 UTC
+++ This bug was initially created as a clone of Bug #1063506 +++

Description of problem:

"gluster volume heal vol info --xml" does not output XML info as i.e. "gluster volume info --xml" does.

Version-Release number of selected component (if applicable):

Tested on 3.4.2 installed on ubuntu 13.10 from semiosis PPA. First observed in 3.4.1

How reproducible:

100%

Steps to Reproduce:
1. Setup a replicate volume
2. Type "gluster volume heal vol info --xml"

Actual results:

Same as without --xml

Expected results:

Should parse into tagged xml for use with APIs etc

Additional info:

Here is a sample

root@testrdp:~# gluster volume heal test1 info --xml
Gathering Heal info on volume test1 has been successful

Brick 10.0.1.152:/mnt/gogo
Number of entries: 0

Brick 10.0.1.205:/mnt/gogo
Number of entries: 0
root@testrdp:~#

root@testrdp:~# gluster volume info --xml
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cliOutput>
<opRet>0</opRet>
<opErrno>0</opErrno>
<opErrstr/>
<volInfo>
<volumes>
<volume>
<name>test1</name>
<id>9dc0c864-84b2-4c6e-8cd9-39e1af272ff3</id>
<status>1</status>
<statusStr>Started</statusStr>
<brickCount>2</brickCount>
<distCount>2</distCount>
<stripeCount>1</stripeCount>
<replicaCount>2</replicaCount>
<type>2</type>
<typeStr>Replicate</typeStr>
<transport>0</transport>
<bricks>
<brick>10.0.1.152:/mnt/gogo</brick>
<brick>10.0.1.205:/mnt/gogo</brick>
</bricks>
<optCount>0</optCount>
<options/>
</volume>
<count>1</count>
</volumes>
</volInfo>
</cliOutput>
root@testrdp:~#

root@testrdp:~# gluster --version
glusterfs 3.4.2 built on Feb 4 2014 23:08:03
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
root@testrdp:~#

--- Additional comment from  on 2014-09-30 10:55:23 EDT ---

FYI: I have upgraded to 3.5.2 and this is still an issue. However, since false positive healing on files with lots of IO is fixed in 3.5.2 this issue is not as big a deal to me. 

Still though, I can imagine someone wanting to use xml output from the heal info command.

--- Additional comment from Niels de Vos on 2015-05-17 17:59:31 EDT ---

GlusterFS 3.7.0 has been released (http://www.gluster.org/pipermail/gluster-users/2015-May/021901.html), and the Gluster project maintains N-2 supported releases. The last two releases before 3.7 are still maintained, at the moment these are 3.6 and 3.5.

This bug has been filed against the 3,4 release, and will not get fixed in a 3.4 version any more. Please verify if newer versions are affected with the reported problem. If that is the case, update the bug with a note, and update the version if you can. In case updating the version is not possible, leave a comment in this bug report with the version you tested, and set the "Need additional information the selected bugs from" below the comment box to "bugs@gluster.org".

If there is no response by the end of the month, this bug will get automatically closed.

--- Additional comment from Sahina Bose on 2015-06-17 06:32:10 EDT ---

We need xml output for volume self heal info, to monitor the self-heal activity of a volume from oVirt.

Changing the version to 3.7.

Comment 1 Vijay Bellur 2016-04-28 08:45:08 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 2 Vijay Bellur 2016-05-03 08:33:40 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 3 Vijay Bellur 2016-05-03 09:15:58 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 4 Vijay Bellur 2016-05-03 14:02:28 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 5 Vijay Bellur 2016-05-05 08:55:23 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 6 Vijay Bellur 2016-05-05 12:14:02 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 7 Vijay Bellur 2016-05-06 13:42:55 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#7) for review on master by hari gowtham (hari.gowtham005@gmail.com)

Comment 8 Vijay Bellur 2016-05-07 04:07:00 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#8) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 9 Vijay Bellur 2016-05-07 15:26:07 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#9) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 10 Vijay Bellur 2016-05-08 01:58:32 UTC
REVIEW: http://review.gluster.org/14100 (heal/xml : xml implementation of heal info and splitbrain info) posted (#10) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 11 Vijay Bellur 2016-05-08 12:19:54 UTC
COMMIT: http://review.gluster.org/14100 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit f0ade919006b2581ae192f997a8ae5bacc2892af
Author: hari gowtham <hgowtham@redhat.com>
Date:   Thu Apr 28 11:48:23 2016 +0530

    heal/xml : xml implementation of heal info and splitbrain info
    
    Current output:
    heal didn't have xml output.
    
    expected output with patch:
    gluster v heal v1 info --xml
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <healInfo>
        <bricks>
          <brick hostUuid="3677edbb-0a6a-415e-b0ee-b846ff93259c">
            <name>10.70.42.183:/home/bricks/b1</name>
            <status>Connected</status>
            <numberOfEntries>0</numberOfEntries>
          </brick>
          <brick hostUuid="3677edbb-0a6a-415e-b0ee-b846ff93259c">
            <name>10.70.42.183:/home/bricks/b2</name>
            <status>Connected</status>
            <numberOfEntries>0</numberOfEntries>
          </brick>
        </bricks>
      </healInfo>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
    </cliOutput>
    
    gluster v heal v1 info split-brain --xml
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <healInfo>
        <bricks>
          <brick hostUuid="3677edbb-0a6a-415e-b0ee-b846ff93259c">
            <name>10.70.42.183:/home/bricks/b1</name>
            <status>Connected</status>
            <numberOfEntries>0</numberOfEntries>
          </brick>
          <brick hostUuid="3677edbb-0a6a-415e-b0ee-b846ff93259c">
            <name>10.70.42.183:/home/bricks/b2</name>
            <status>Connected</status>
            <numberOfEntries>0</numberOfEntries>
          </brick>
        </bricks>
      </healInfo>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
    </cliOutput>
    
    Change-Id: I20ad5eb7950d4721364ab46089e3af515162db82
    BUG: 1331287
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/14100
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Tested-by: Ravishankar N <ravishankar@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 12 Shyamsundar 2017-03-27 18:21:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.