Bug 1331313 - Lack of placeholder package after install RHEV-H ng 4.0
Summary: Lack of placeholder package after install RHEV-H ng 4.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-release-rhev-hypervisor
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.0-rc
: 4.0.1
Assignee: Ryan Barry
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Depends On:
Blocks: ovirt-node-ng
TreeView+ depends on / blocked
 
Reported: 2016-04-28 09:24 UTC by Huijuan Zhao
Modified: 2016-08-23 21:11 UTC (History)
11 users (show)

Fixed In Version: redhat-virtualization-host-4.0-20160713.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:11:16 UTC
oVirt Team: Node
Target Upstream Version:
huzhao: testing_plan_complete+


Attachments (Terms of Use)
The log (5.96 MB, application/x-gzip)
2016-04-28 09:24 UTC, Huijuan Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1688 normal SHIPPED_LIVE redhat-release-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:37:04 UTC

Description Huijuan Zhao 2016-04-28 09:24:06 UTC
Created attachment 1151784 [details]
The log

Description of problem:
Lack of placeholder package after install RHEV-H 4.0, and this will cause repeat update to the same build.
For the upstream NGN4.0, there is placeholder package(ovirt-node-ng-image-placeholder-*) after installation.


Version-Release number of selected component (if applicable):
rhev-hypervisor7-ng-3.6-20160426.0.x86_64
imgbased-0.6-0.1.el7ev.noarch

rhev-hypervisor7-ng-image-update-3.6-20160426.0.el7.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-ng-3.6-20160426.0.x86_64
2. Login rhev-h, check packages
3. Download rhev-hypervisor7-ng-image-update-3.6-20160426.0.el7.noarch.rpm
4. yum install rhev-hypervisor7-ng-image-update-3.6-20160426.0.el7.noarch.rpm

Actual results:
1. After step2, there is no placeholder or update packages
2. After step4, enter to upgrade process and upgrade complete

Expected results:
1. After step2, there should have placeholder package for upgrade.
2. After step4, it should not enter to upgrade process and give warning about "Error: Nothing to do".

Additional info:

Comment 1 Fabian Deutsch 2016-04-29 12:38:01 UTC
The redhat-release-rhev-hypervisor package needs to provide the placeholder

Comment 3 Yaniv Lavi 2016-05-09 11:05:36 UTC
oVirt 4.0 Alpha has been released, moving to oVirt 4.0 Beta target.

Comment 6 Huijuan Zhao 2016-06-01 09:28:09 UTC
Still encounter this issue on redhat-release-rhev-hypervisor-3.6-0.27.el7.x86_64, so I will change the status to ASSIGNED.


Test Version:
rhev-hypervisor7-ng-3.6-20160518.0
imgbased-0.6-0.1.el7ev.noarch
redhat-release-rhev-hypervisor-3.6-0.27.el7.x86_64
rhev-hypervisor7-ng-image-update-3.6-20160518.0.el7.noarch.rpm

Steps to Reproduce:
1. Install rhev-hypervisor7-ng-3.6-20160518.0.x86_64
2. Login rhev-h, check packages
3. Download rhev-hypervisor7-ng-image-update-3.6-20160518.0.el7.noarch.rpm
4. yum install rhev-hypervisor7-ng-image-update-3.6-20160518.0.el7.noarch.rpm

Actual results:
1. After step2, there is no placeholder or update packages
2. After step4, enter to upgrade process and upgrade complete

Expected results:
1. After step2, there should have placeholder package for upgrade.
2. After step4, it should not enter to upgrade process and give warning about "Error: Nothing to do".

Additional info:
Still encounter this issue on rhev-hypervisor7-ng-4.0-20160527.0.
Now, all the downstream builds(NGN 3.6 and 4.0) do not support upgrade, so do not have placeholder package.

Comment 8 Douglas Schilling Landgraf 2016-06-10 03:41:58 UTC
# rpm -qa | grep -i placeholder
rhev-hypervisor7-ng-image-update-placeholder-4.0-0.6.el7.noarch

Comment 9 Huijuan Zhao 2016-06-16 06:45:33 UTC
Test version:
rhev-hypervisor7-ng-4.0-20160609.0
rhev-hypervisor7-ng-image-update-placeholder-4.0-0.6.el7.noarch
redhat-release-rhev-hypervisor-4.0-0.6.el7.x86_64
imgbased-0.7.0-0.1.el7ev.noarch

Test steps:
1. Install rhev-hypervisor7-ng-4.0-20160609.0
2. Login ngn and check the placeholder package
# rpm -qa | grep -i placeholder

Test results:
After step2,
[root@dhcp-8-252 ~]# rpm -qa | grep placeholder
rhev-hypervisor7-ng-image-update-placeholder-4.0-0.6.el7.noarch

So the placeholder package issue is fixed in rhev-hypervisor7-ng-4.0-20160609.0.
And for another issue of upgrade to itself in Comment 0, Bug 1334874 will track this.
So I will change the status to verified.

Comment 10 Huijuan Zhao 2016-07-12 06:21:56 UTC
Still encounter this issue on redhat-virtualization-host-4.0-20160708.0.x86_64.

Test version:
redhat-virtualization-host-4.0-20160708.0.x86_64
redhat-release-virtualization-host-4.0-0.13.el7.x86_64
imgbased-0.7.2-0.1.el7ev.noarch


Test steps:
1. Install redhat-virtualization-host-4.0-20160708.0.x86_64
2. Login rhev-h, check packages:
   # rpm -qa | grep placeholder

Actual result:
1. After step2, there is no placeholder package

Expected result:
1. After step2, there should be placeholder package

So I will reopen this bug, and this is a regression bug according to comment 9.

Comment 13 Ryan Barry 2016-07-12 13:05:00 UTC
(In reply to Huijuan Zhao from comment #10)
> Still encounter this issue on
> redhat-virtualization-host-4.0-20160708.0.x86_64.
> 
> Test version:
> redhat-virtualization-host-4.0-20160708.0.x86_64
> redhat-release-virtualization-host-4.0-0.13.el7.x86_64
> imgbased-0.7.2-0.1.el7ev.noarch
> 
> 
> Test steps:
> 1. Install redhat-virtualization-host-4.0-20160708.0.x86_64
> 2. Login rhev-h, check packages:
>    # rpm -qa | grep placeholder
> 
> Actual result:
> 1. After step2, there is no placeholder package
> 
> Expected result:
> 1. After step2, there should be placeholder package
> 
> So I will reopen this bug, and this is a regression bug according to comment
> 9.

Test version:

redhat-virtualization-host-4.0-20160708.0

rpm -qa |grep lace
redhat-virtualization-host-image-update-placeholder-4.0-0.13.el7.noarch

Can you please retest?

Comment 14 Huijuan Zhao 2016-07-13 02:24:38 UTC
So wired, we tested this issue both on iso and liveimg.squashfs, both have NO redhat-virtualization-host-image-update-placeholder-4.0-0.13.el7.noarch.

We loaded redhat-virtualization-host-4.0-20160708.0 from the link in your smoke test email, and md5sum is as follow:
# md5sum RHVH-7.2-20160708.2-RHVH-x86_64-dvd1.iso
f19c423e6c26e3ef0c0feabf6e209ba0  RHVH-7.2-20160708.2-RHVH-x86_64-dvd1.iso


Ryan, could you check if we used the same iso ? Thanks.

Comment 15 Ryan Barry 2016-07-13 02:53:25 UTC
The smoke testing reports are sent using the squashfs.

Since the ISO distill is no longer done by the node team, the usual method of testing is to generate and test a squashfs, request a distill from releng, test installation, then send it.

My test (from the last comment) was made directly from a PXE booted squashfs (which I still have).

However, it's not present in the squashfs from brew.

This will be resolved in the next build (tomorrow)

Comment 16 Huijuan Zhao 2016-07-14 03:37:41 UTC
Test version:
redhat-virtualization-host-4.0-20160713.0.x86_64
redhat-release-virtualization-host-4.0-0.18.el7.x86_64
imgbased-0.7.2-0.1.el7ev.noarch
redhat-virtualization-host-image-update-placeholder-4.0-0.18.el7.noarch

Test steps:
1. Install redhat-virtualization-host-4.0-20160713.0.x86_64
2. Login rhev-h, check packages:
   # rpm -qa | grep placeholder

Test result:
1. After step2, 
# rpm -qa | grep place
redhat-virtualization-host-image-update-placeholder-4.0-0.18.el7.noarch

So this issue is fixed on redhat-virtualization-host-4.0-20160713.0.x86_64, change the status to VERIFIED

Comment 18 errata-xmlrpc 2016-08-23 21:11:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1688.html


Note You need to log in before you can comment on or make changes to this bug.