Bug 1331317 - Server-dvd doesn't boot from flash drive created by dd
Summary: Server-dvd doesn't boot from flash drive created by dd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pungi
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-04-28 09:44 UTC by Petr Schindler
Modified: 2016-06-14 08:41 UTC (History)
11 users (show)

Fixed In Version: pungi-4.0.15-1.fc23 pungi-4.0.15-1.fc24 pungi-4.0.15-2.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-14 08:41:14 UTC


Attachments (Terms of Use)

Description Petr Schindler 2016-04-28 09:44:00 UTC
Description of problem:
I tried to put beta 1.1 server dvd on usb with dd. And it didn't boot (uefi doesn't even show in list). Disk was umounted before dd and synced after. It doesn't boot with 20160424 compose too.

Server dvd boots in virtual machine and when the livecd-iso-to-disk is used. Live and netinst works fine with dd.

I propose this as beta blocker as it violates the beta criterion: "
All release-blocking images must boot in their supported configurations.

Supported media types

Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods."

Version-Release number of selected component (if applicable):
Beta 1.1

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Kamil Páral 2016-04-28 09:55:36 UTC
I can confirm this (different flash drive, different computer). Please note that both of us are running Fedora 24 (in case it's a bug in dd). I also tested writing it with gnome-disks, same problem. UEFI boot doesn't show up at all, BIOS boot does show up, but after selecting it the computer immediately switches to a different boot method (boots from hdd, pxe, etc). No error is displayed.

I have verified that the sha256 checksum our of image matches, so it's not a corrupted download. Please note that the DVD.iso does boot in VM just fine (BIOS boot tested), which I find very confusing (I'd expect both broken or both working).

coreutils-8.25-5.fc24.x86_64
gnome-disk-utility-3.20.1-1.fc24.x86_64
https://kojipkgs.fedoraproject.org/compose/24/Fedora-24-20160428.0/compose/Server/x86_64/iso/Fedora-Server-dvd-x86_64-24_Beta-1.1.iso

Comment 2 Jan Sedlák 2016-04-28 11:35:45 UTC
It also doesn't work when done from Fedora 23.

I have these versions:
coreutils-8.24-6.fc23.x86_64
gnome-disk-utility-3.18.3.1-1.fc23.x86_64

Comment 3 Kamil Páral 2016-04-28 15:15:46 UTC
This problem was not present with Alpha DVD, I just tried it, it boots OK, both BIOS and UEFI.

Comment 4 Stephen Gallagher 2016-04-28 17:10:19 UTC
Seems like an obvious blocker to me. +1

Comment 5 Adam Williamson 2016-04-28 17:41:21 UTC
yeah, this has been confirmed by several people now and is obviously a blocker, the image seems to be messed up. cmurf reports that the netinst iso is fine, which is odd. +1 blocker.

Comment 6 Kamil Páral 2016-04-28 18:33:12 UTC
+1 blocker

Comment 7 Chris Murphy 2016-04-28 19:15:15 UTC
Basically the server DVD does not have an MBR or GPT so used as non-optical device the firmware can't boot it. But it is a valid ISO 9660 file, zeros up to 0x8000 where the ISO 9660 magic "CD001" is found. This is why the VM can boot the media when attaching as a CDROM device (which have their own bootstrap mechanism rather than depending on MBR/GPT).

So whatever's responsible for creating the hybrid partition map(s) used for ISOs is MIA for server dvd specifically.

Comment 8 Adam Williamson 2016-04-28 22:07:22 UTC
https://pagure.io/pungi/pull-request/285

Comment 9 Petr Schindler 2016-04-29 05:40:40 UTC
Still happens with Beta 1.2

Comment 10 Adam Williamson 2016-04-29 06:28:49 UTC
yes, of course. the fix is not yet merged and was not used for 1.2.

Comment 11 Fedora Update System 2016-04-29 21:07:19 UTC
pungi-4.0.15-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-66d3344495

Comment 12 Fedora Update System 2016-04-29 21:07:48 UTC
pungi-4.0.15-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a1b48953d4

Comment 13 Fedora Update System 2016-04-30 18:21:37 UTC
pungi-4.0.15-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-66d3344495

Comment 14 Adam Williamson 2016-04-30 18:31:40 UTC
This bug ought to be fixed in the Beta-1.4 compose.

Comment 15 Chris Murphy 2016-04-30 20:11:58 UTC
It definitely has a bootloader and partition map LBA 0-2. And it boots a VM when used as a hard drive. I'm writing a stick now and can make sure it boots real hardware shortly.

Comment 16 Chris Murphy 2016-04-30 21:09:52 UTC
Boots an Intel NUC from dd'd USB stick, no problem through Aanconda's Welcome to Fedora 24 screen.

Comment 17 Adam Williamson 2016-04-30 21:43:44 UTC
Great, we can call this VERIFIED then.

Comment 18 Fedora Update System 2016-05-01 01:24:16 UTC
pungi-4.0.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a1b48953d4

Comment 19 Petr Schindler 2016-05-02 08:39:09 UTC
I tested it with Beta 1.4 and it works as it should.

Comment 20 Adam Williamson 2016-05-02 21:38:07 UTC
If you used Beta 1.4 and it worked fine, you can +1 https://bodhi.fedoraproject.org/updates/FEDORA-2016-a1b48953d4 .

Comment 21 Fedora Update System 2016-05-04 18:52:34 UTC
pungi-4.0.15-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2016-05-07 09:24:55 UTC
pungi-4.0.15-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Kamil Páral 2016-06-07 08:38:25 UTC
The same problem is again present with Fedora-Server-dvd-x86_64-24-20160606.n.0.iso. The image boots in VM, but does not boot on bare metal. Exactly the same symptoms.

Since it was already accepted as Beta blocker, I'm just moving the milestone to Final, and keeping the accepted flag.

Comment 24 Lubomír Sedlář 2016-06-07 09:05:12 UTC
This is the koji task that made the ISO:
http://koji.fedoraproject.org/koji/taskinfo?taskID=14392210

Apparently pungi 4.0.14-3 is used there. That version does not have the fix. As far as I can tell, all branched composes listed at [0] used this version.

[0] https://kojipkgs.fedoraproject.org/compose/branched/

Comment 25 Adam Williamson 2016-06-07 14:58:31 UTC
That's odd, as 4.0.15-1 was pushed stable for both F23 and F24 already...dennis?

Comment 26 Dennis Gilmore 2016-06-09 14:16:34 UTC
a buildroot override expired. and the incorrect pungi version was used.  We should make sure we push pungi stable for GA

Comment 27 Adam Williamson 2016-06-09 16:57:59 UTC
but it already *was* pushed stable, according to Bodhi.

Comment 28 Dennis Gilmore 2016-06-09 21:43:03 UTC
koji list-history --tag=f24 --package=pungi
Tue Jul 14 23:34:21 2015 pungi-4.0.1-2.fc23 tagged into f24 by ausil
Fri Jul 24 13:09:55 2015 pungi-4.0.2-1.fc24 tagged into f24 by ausil
Tue Sep  8 22:15:23 2015 pungi-4.0.3-1.fc24 tagged into f24 by ausil
Wed Jan 20 09:55:01 2016 pungi-4.0.4-1.fc24 tagged into f24 by ausil [still active]
Thu Jan 21 19:57:26 2016 pungi-4.0.1-2.fc23 untagged from f24 by oscar
Sat Feb  6 03:29:12 2016 pungi-4.0.4-2.fc24 tagged into f24 by releng [still active]
Sun Feb  7 12:57:28 2016 pungi-4.0.2-1.fc24 untagged from f24 by oscar
Tue Feb 23 12:50:00 2016 pungi-4.0.5-1.fc24 tagged into f24 by ausil [still active]
Fri Feb 26 10:35:56 2016 pungi-4.0.6-1.fc24 tagged into f24 by ausil [still active]
Thu Mar  3 07:44:30 2016 pungi-4.0.3-1.fc24 untagged from f24 by oscar
Thu Mar  3 14:33:39 2016 pungi-4.0.7-1.fc24 tagged into f24 by ausil [still active]
Wed Apr 27 18:50:14 2016 package list entry created: pungi in f24 by pkgdb [still active]
Sat May  7 04:24:19 2016 pungi-4.0.15-1.fc24 tagged into f24 by bodhi [still active]
Sat May  7 06:33:40 2016 pungi-4.0.14-3.fc24 tagged into f24 by bodhi [still active]


bodhi pushed an older package stable afterwards

we need pungi-4.0.15-2.fc24 for dealling with the move of comps and kickstarts to pagure

Comment 29 Fedora Update System 2016-06-09 21:44:01 UTC
pungi-4.0.15-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa49938267

Comment 30 Fedora Update System 2016-06-14 08:41:10 UTC
pungi-4.0.15-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.