Bug 1331354 - RHEV-H NG: Anaconda exception occur during anaconda install on local machine
Summary: RHEV-H NG: Anaconda exception occur during anaconda install on local machine
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-release-rhev-hypervisor
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ovirt-4.0.0-rc
: 4.0.0
Assignee: Fabian Deutsch
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks: ovirt-node-ng
TreeView+ depends on / blocked
 
Reported: 2016-04-28 11:01 UTC by cshao
Modified: 2016-08-23 21:11 UTC (History)
10 users (show)

Fixed In Version: rhev-hypervisor7-ng-4.0-20160607.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:11:35 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
all log info (145.02 KB, application/x-gzip)
2016-04-28 11:01 UTC, cshao
no flags Details
anaconda_exception (891.63 KB, image/png)
2016-04-28 11:13 UTC, cshao
no flags Details
all log info (124.03 KB, application/x-gzip)
2016-05-12 07:28 UTC, cshao
no flags Details
ngm.ks (165 bytes, text/plain)
2016-05-12 08:04 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1688 normal SHIPPED_LIVE redhat-release-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:37:04 UTC

Description cshao 2016-04-28 11:01:48 UTC
Created attachment 1151822 [details]
all log info

Description of problem:
RHEV-H NG: Anaconda exception occur during anaconda install on local machine


15:48:49,807 INFO anaconda: Configuring addons
15:48:49,830 DEBUG anaconda: running handleException
15:48:49,832 CRIT anaconda: Traceback (most recent call last):

  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)

  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)

  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 104, in doConfiguration
    ksdata.addons.execute(storage, ksdata, instClass, u)

  File "/usr/lib64/python2.7/site-packages/pyanaconda/addons.py", line 84, in execute
    v.execute(storage, ksdata, instClass, users)

  File "/usr/share/anaconda/addons/org_fedora_oscap/ks/oscap.py", line 525, in execute
    self.postinst_tailoring_path, chroot=getSysroot())

  File "/usr/share/anaconda/addons/org_fedora_oscap/common.py", line 219, in run_oscap_remediate
    raise OSCAPaddonError(msg)

OSCAPaddonError: Failed to run the oscap tool: [Errno 2] No such file or directory

15:48:49,832 DEBUG anaconda: Gtk running, queuing exception handler to the main loop

Version-Release number of selected component (if applicable):
rhev-hypervisor7-ng-3.6-20160426.0.x86_64
imgbased-0.6-0.1.el7ev.noarch

How reproducible:
30%

Steps to Reproduce:
1. Install rhev-hypervisor7-ng-3.6-20160426.0.x86_64 on local machine(only one disk)
2. Set keyboard/Network/Hostname/Security Policy/kdump.
3. Begin the installation.

Actual results:
Anaconda exception occur during anaconda install on local machine

Expected results:
No exception occur during anaconda install on local machine

Additional info:

Comment 1 cshao 2016-04-28 11:13:10 UTC
Created attachment 1151835 [details]
anaconda_exception

Comment 2 Fabian Deutsch 2016-04-28 12:26:23 UTC
Not sure how this is expected to work correctly.

Vratislav, can you tell if anaconda expects the relevant oscap tools to be available in the rootfs?

I am just not sure why oscap turns up if it was not mentioned anywhere.

Comment 3 Vratislav Podzimek 2016-04-29 08:33:51 UTC
The problem here is that the OSCAP addon should be in both the installer environment and the installed system or in none of the places.

Comment 6 cshao 2016-05-12 07:27:57 UTC
Test version:
rhev-hypervisor7-ng-20160506.0.el7
imgbased-0.6-0.1.el7ev.noarch
cockpit-ovirt-0.5.1-0.0.ovirt40.el7ev.x86_64
redhat-release-rhev-hypervisor-3.6-0.20.el7.x86_64

Test steps:
1. Install rhev-hypervisor7-ng-3.6-20160506.0.x86_64 on local machine(only one disk)
2. Set keyboard/Network/Hostname/Security Policy/kdump.
3. Begin the installation.

Test result:
Anaconda exception occur during anaconda install on local machine

I have to change the bug status to ASSIGNED.

Comment 7 cshao 2016-05-12 07:28:34 UTC
Created attachment 1156489 [details]
all log info

Comment 8 cshao 2016-05-12 08:04:22 UTC
Created attachment 1156496 [details]
ngm.ks

Comment 9 Fabian Deutsch 2016-05-12 08:49:08 UTC
Vartislav, in anaconda-tb I see:

anaconda 21.48.22.56-1 exception report
Traceback (most recent call first):
  File "/usr/share/anaconda/addons/org_fedora_oscap/common.py", line 230, in run_oscap_remediate
    raise OSCAPaddonError(msg)
  File "/usr/share/anaconda/addons/org_fedora_oscap/ks/oscap.py", line 525, in execute
    self.postinst_tailoring_path, chroot=getSysroot())
  File "/usr/lib64/python2.7/site-packages/pyanaconda/addons.py", line 84, in execute
    v.execute(storage, ksdata, instClass, users)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 104, in doConfiguration
    ksdata.addons.execute(storage, ksdata, instClass, u)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
OSCAPaddonError: Content evaluation and remediation with the oscap tool failed: I/O warning : failed to load external entity "/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml"
OpenSCAP Error: failed to load external entity "/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml" [oscap_source.c:186]
Unable to parse XML at: '/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml' [oscap_source.c:187]


Local variables in innermost frame:
profile: common
chroot: /mnt/sysimage
stdout: 
tailoring: None
args: ['oscap', 'xccdf', 'eval', '--remediate', '--results=/root/openscap_data/eval_remediate_results.xml', '--profile=common', '/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml']
ds_id: 
results_dir: /mnt/sysimage/root/openscap_data
fpath: /usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml
xccdf_id: 
stderr: I/O warning : failed to load external entity "/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml"
OpenSCAP Error: failed to load external entity "/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml" [oscap_source.c:186]
Unable to parse XML at: '/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml' [oscap_source.c:187]

msg: Content evaluation and remediation with the oscap tool failed: I/O warning : failed to load external entity "/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml"
OpenSCAP Error: failed to load external entity "/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml" [oscap_source.c:186]
Unable to parse XML at: '/usr/share/xml/scap/ssg/content/ssg-rhel7-xccdf.xml' [oscap_source.c:187]

do_chroot: <function do_chroot at 0x6f5dc08>
proc: <subprocess.Popen object at 0x6f67b50>

Any idea?

Comment 10 Vratislav Podzimek 2016-05-12 08:54:15 UTC
Is the scap-security-guide package part of the installed system?

Comment 11 Fabian Deutsch 2016-05-12 08:58:37 UTC
Not, it is not part of the list. Adding it.

Comment 12 cshao 2016-06-08 08:59:16 UTC
Hi Fabian,

For more accurate verify this bug, could you please add "Fixed In Version" area as well?

Thanks!

Comment 13 cshao 2016-06-16 06:11:45 UTC
rhev-hypervisor7-ng-4.0-20160608.0(beta) 
imgbased-0.7.0-0.1.el7ev.noarch
redhat-release-rhev-hypervisor-4.0-0.6.el7.x86_64

After several times testing on local machine, no exception occur during anaconda interactive installation. so the bug is fixed, change bug status to VERIFIED.

Comment 15 errata-xmlrpc 2016-08-23 21:11:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1688.html


Note You need to log in before you can comment on or make changes to this bug.