Bug 1331355 - Undercloud contains test MySQL database
Summary: Undercloud contains test MySQL database
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Emilien Macchi
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-28 11:02 UTC by Marius Cornea
Modified: 2017-05-17 19:29 UTC (History)
11 users (show)

Fixed In Version: instack-undercloud-6.0.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:29:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 412625 None None None 2016-12-19 21:56:35 UTC

Description Marius Cornea 2016-04-28 11:02:10 UTC
Description of problem:
The undercloud contains 'test' MySQL database.

Version-Release number of selected component (if applicable):
instack-undercloud-2.2.7-4.el7ost.noarch
instack-0.0.8-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install undercloud 
2. sudo mysql -e 'show databases;'

Actual results:
stack@instack:~>>> sudo mysql -e 'show databases;'
+--------------------+
| Database           |
+--------------------+
| information_schema |
| ceilometer         |
| glance             |
| heat               |
| ironic             |
| keystone           |
| mysql              |
| neutron            |
| nova               |
| performance_schema |
| test               |
+--------------------+

Expected results:
The test database should be deleted.

Comment 5 Emilien Macchi 2017-04-03 21:34:13 UTC
Can you verify it please?

Comment 8 Marius Cornea 2017-04-10 11:01:32 UTC
[stack@undercloud-0 ~]$  sudo mysql -e 'show databases;'
+--------------------+
| Database           |
+--------------------+
| information_schema |
| aodh               |
| ceilometer         |
| glance             |
| gnocchi            |
| heat               |
| ironic             |
| ironic-inspector   |
| keystone           |
| mistral            |
| mysql              |
| neutron            |
| nova               |
| nova_api           |
| nova_cell0         |
| nova_placement     |
| panko              |
| performance_schema |
+--------------------+

Comment 9 errata-xmlrpc 2017-05-17 19:29:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.