Bug 1331372 (CVE-2016-4049) - CVE-2016-4049 quagga: denial of service vulnerability in BGP routing daemon
Summary: CVE-2016-4049 quagga: denial of service vulnerability in BGP routing daemon
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2016-4049
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=moderate,public=20160427,repor...
Depends On: 1331373 1391919
Blocks: 1331374 1386080
TreeView+ depends on / blocked
 
Reported: 2016-04-28 12:01 UTC by Martin Prpič
Modified: 2019-06-11 11:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A denial of service flaw was found in the Quagga BGP routing daemon (bgpd). Under certain circumstances, a remote attacker could send a crafted packet to crash the bgpd daemon resulting in denial of service.
Clone Of:
Environment:
Last Closed: 2019-06-08 02:51:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0794 normal SHIPPED_LIVE Moderate: quagga security and bug fix update 2017-03-21 12:50:48 UTC

Description Martin Prpič 2016-04-28 12:01:40 UTC
A denial of service flaw was found in the Quagga BGP routing daemon (bgpd). Under certain circumstances, an attacker could use a crafted packet to crash the bgpd service.

External References:

http://openwall.com/lists/oss-security/2016/04/27/7

Comment 1 Martin Prpič 2016-04-28 12:01:58 UTC
Created quagga tracking bugs for this issue:

Affects: fedora-all [bug 1331373]

Comment 5 errata-xmlrpc 2017-03-21 11:58:43 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6

Via RHSA-2017:0794 https://rhn.redhat.com/errata/RHSA-2017-0794.html


Note You need to log in before you can comment on or make changes to this bug.