Bug 133138 - Python bindings for ATK appear not to bind atk_add_global_event_listener
Python bindings for ATK appear not to bind atk_add_global_event_listener
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks: 133136
  Show dependency treegraph
 
Reported: 2004-09-21 16:26 EDT by Dave Malcolm
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 16:13:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 371716 None None None Never

  None (edit)
Description Dave Malcolm 2004-09-21 16:26:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
import atk
dir (atk) lists remove_global_event_listener but does not list
add_global_event_listener.

Can't find it in atk.Util either.

Appears to be wrapped, looking at latest version in CVS; am I being
daft and not spotting it, are we up-to-date, or has something gone
wrong with the bindings?

Version-Release number of selected component (if applicable):
pygtk2-2.3.96-2

How reproducible:
Always

Steps to Reproduce:
1. python
2. import atk
3. dir (atk)
    

Additional info:
Comment 1 Dave Malcolm 2004-09-27 18:01:36 EDT
I just had a go at trying to build the latest version in pygtk2/devel
(2.3.96-2); the following error messages during code generation look
like the cause of the problem:

Could not write method AtkObject.connect_property_change_handler: No
ArgType for 'AtkPropertyChangeHandler*'
Could not write method AtkObject.notify_state_change: No ArgType for
'AtkState'
Warning: generating old-style constructor for atk_no_op_object_new
Could not write method AtkRelation.get_target: No ArgType for 'GPtrArray*'
Could not write method AtkStateSet.add_states: No ArgType for
'AtkStateType*'
Could not write method AtkStateSet.contains_states: No ArgType for
'AtkStateType*'
Could not write function add_focus_tracker: No ArgType for
'AtkEventListener'
Could not write function focus_tracker_init: No ArgType for
'AtkEventListenerInit'
Could not write function add_global_event_listener: No ArgType for
'GSignalEmissionHook'
Could not write function add_key_event_listener: No ArgType for
'AtkKeySnoopFunc'
Comment 2 Need Real Name 2006-04-12 11:04:28 EDT
This should be moved upstream..
Comment 3 Matthew Barnes 2006-11-06 16:13:29 EST
Moving this upstream.

Please see http://bugzilla.gnome.org/show_bug.cgi?id=371716.

Note You need to log in before you can comment on or make changes to this bug.