Bug 1331423 - distaf: Add io_libs to namespace package list
Summary: distaf: Add io_libs to namespace package list
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-28 13:34 UTC by M S Vishwanath Bhat
Modified: 2017-03-27 18:15 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 18:15:01 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description M S Vishwanath Bhat 2016-04-28 13:34:08 UTC
Description of problem:
Currently io_libs is outside of namespace package list inside distaflibs. The other tests in gluster needs io_libs and hence we need to include this.

Version-Release number of selected component (if applicable):
git-master

How reproducible:
Always

Steps to Reproduce:
1. Check io_libs in glusterfs.git/tests/distaf/distaf_libs/io_libs

Actual results:
They are not part of the namespace package (Actually it is not a package at all ATM)

Expected results:
We need to make this a part of namespace package.

Additional info:

Rename distaflibs-gluster to just gluster.

Comment 1 Vijay Bellur 2016-04-29 15:14:04 UTC
REVIEW: http://review.gluster.org/14119 (Adding io_libs to the distaflibs namespace packages) posted (#1) for review on master by M S Vishwanath Bhat (vbhat@redhat.com)

Comment 2 Vijay Bellur 2016-05-03 13:48:31 UTC
REVIEW: http://review.gluster.org/14119 (Adding io_libs to the distaflibs namespace packages) posted (#2) for review on master by M S Vishwanath Bhat (vbhat@redhat.com)

Comment 3 Vijay Bellur 2016-05-05 11:56:19 UTC
REVIEW: http://review.gluster.org/14119 (Adding io_libs to the distaflibs namespace packages) posted (#3) for review on master by M S Vishwanath Bhat (vbhat@redhat.com)

Comment 4 Vijay Bellur 2016-05-05 18:45:04 UTC
REVIEW: http://review.gluster.org/14119 (Adding io_libs to the distaflibs namespace packages) posted (#4) for review on master by M S Vishwanath Bhat (vbhat@redhat.com)

Comment 5 Vijay Bellur 2016-05-06 08:44:47 UTC
COMMIT: http://review.gluster.org/14119 committed in master by M S Vishwanath Bhat (vbhat@redhat.com) 
------
commit 9de751eddb89eec3715c1a5dbb36b8b655d3f3a8
Author: M S Vishwanath Bhat <msvbhat@gmail.com>
Date:   Fri Apr 29 20:38:23 2016 +0530

    Adding io_libs to the distaflibs namespace packages
    
    Following the gluster_libs, which was added to distaflibs
    namespace package, this patch also adds io_libs to the same
    namespace package.
    
    Change-Id: Ife62f2dd0c966579546426a9dbc1a71d8c154292
    BUG: 1331423
    Signed-off-by: M S Vishwanath Bhat <msvbhat@gmail.com>
    Reviewed-on: http://review.gluster.org/14119
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jonathan Holloway <jholloway@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 8 Shyamsundar 2017-03-27 18:15:01 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.