This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 133145 - avc denied for tmpfs during boot
avc denied for tmpfs during boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks: FC3Blocker FC3BugWeekQA
  Show dependency treegraph
 
Reported: 2004-09-21 17:19 EDT by John Reiser
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 13:11:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
grep "avc:" /var/log/messages # plus all selinux-related lines, to show context (6.02 KB, text/plain)
2004-09-21 17:21 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2004-09-21 17:19:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
During boot to multiuser runlevel 5, there are various messages "avc:
denied" with tmpfs_t being the common element.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.18-3

How reproducible:
Always

Steps to Reproduce:
1. Boot to runlevel 5 using kernel-2.6.8-1.541, initscripts-7.82-1,
and selinux-policy-targeted-1.17.18-3 in permissive mode.
2.
3.
    

Actual Results:  12 lines in /var/log/messages with "avc: denied", all
featuring tmpfs_t.


Expected Results:  No complaints.

Additional info:

Selected lines will be attached (all lines from /var/log/messages
relating to selinux, in order.)
Comment 1 John Reiser 2004-09-21 17:21:59 EDT
Created attachment 104090 [details]
grep "avc:" /var/log/messages  # plus all selinux-related lines, to show context

I see 12 lines with avc: complaints.
Comment 2 Daniel Walsh 2004-09-22 10:13:53 EDT
THis is caused because the tmpfs xattr patch was pulled from the
kernel.  Please use the previous kernel (FC3-T2 kernel) until we have
this sorted out.

Dan
Comment 3 Warren Togami 2004-10-09 18:24:39 EDT
kernel-2.6.8-1.541 is supposed to have tmpfs + xattrs.  The next
working tmpfs + xattrs kernel was 598+.  Reiser mentions "permissive"
mode.  Are the xattrs being set properly in permissive mode?
Comment 4 John Reiser 2004-10-09 19:51:40 EDT
I see no complaints when booting to targeted, permissive mode using:
  kernel-2.6.8-1.541
  selinux-policy-targeted-1.17.24-2
  initscripts-7.85-1
The /var/log/messages at boot has:
  Oct  9 16:44:38 localhost kernel: SELinux: initialized (dev tmpfs,
type tmpfs), uses transition SIDs
[I stopped running up2date on Oct.4 because my reading of
fedora-test-list convinced me that FC3test2 had entered a phase of
instability that was more than I wanted to handle.]
Comment 5 Daniel Walsh 2004-10-09 21:02:15 EDT
Fixed with latest kernel (603) and policy-1.17.29-1.  
Comment 6 Colin Walters 2004-10-15 13:11:01 EDT
Yeah, we can mark this as fixed.

Note You need to log in before you can comment on or make changes to this bug.