Bug 133147 - (Radeon Mobility) Screen flickers and goes blank on IBM Thinkpad R40 in X session
(Radeon Mobility) Screen flickers and goes blank on IBM Thinkpad R40 in X ses...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-21 17:35 EDT by Ben Ramsey
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 17:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X config file from /etc/X11/xorg.conf (2.70 KB, text/plain)
2004-09-22 09:32 EDT, Ben Ramsey
no flags Details
X log file from /var/log/Xorg.*.log (36.20 KB, text/plain)
2004-09-22 09:33 EDT, Ben Ramsey
no flags Details
X config file from /etc/X11/xorg.conf (3.04 KB, text/plain)
2004-12-02 12:01 EST, Ben Ramsey
no flags Details
X log file from /var/log/Xorg.*.log (37.47 KB, text/plain)
2004-12-02 12:02 EST, Ben Ramsey
no flags Details

  None (edit)
Description Ben Ramsey 2004-09-21 17:35:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
When booting up in graphical mode, lines will begin flickering in the
display. The flickering lines become more and more frequent and the
display begins to degrade to the point that it goes blank. However,
the light in the LCD monitor is still on, because there is still a
glow; it is just black. 

Pressing Ctrl+Alt+F2 while it is doing this does take me to a
full-screen terminal; however, the flickering still continues until
the screen goes completely blank. I have blindly logged in through the
terminal to reboot the machine.

At the grub boot loader, I can edit the kernel line, adding 'linux 3'
to boot into runlevel 3. This works just fine, but I don't know where
to go from here to find out more information as to why this is
happening. I have examined /etc/X11/xorg.conf, but everything looks
good (as far as I know).

Adding 'nofb' to the kernel line in the boot loader doesn't seem to
have any affect.

The machine is an IBM Thinkpad R40 2681-Q6U. The video card that
xorg.conf has listed is an "ATI Radeon Mobility 7500".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start-up computer in run-level 5
2.Sit and watch as the display degrades with flickering
    

Actual Results:  Screen goes blank after a few minutes

Expected Results:  Screen should be clear and fine. I have a Windows
partition on the same machine, and it works just fine, so I don't
think it's a hardware issue.

Additional info:
Comment 3 Mike A. Harris 2004-09-21 19:11:08 EDT
Thanks for the bug report.  We have reviewed the information you
have provided above, and there is some additional information we
require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X
server log file (/var/log/Xorg.*.log) to the bug report as individual
uncompressed file attachments using the bugzilla file attachment link
below.

We will review this issue again once you've had a chance to attach
this information.

Thanks in advance.

Comment 4 Ben Ramsey 2004-09-22 09:32:53 EDT
Created attachment 104122 [details]
X config file from /etc/X11/xorg.conf
Comment 5 Ben Ramsey 2004-09-22 09:33:39 EDT
Created attachment 104123 [details]
X log file from /var/log/Xorg.*.log
Comment 6 Ben Ramsey 2004-09-22 21:24:55 EDT
Not sure if anyone noticed, but I've attached the requested files.

Thanks.
Comment 7 Ben Ramsey 2004-09-28 10:56:35 EDT
Since FC3test2 is running xorg-x11-6.8.0, I found RPMs for version
6.8.1 (the latest version) at
http://rpm.pbone.net/index.php3/stat/14/idka/24156/datan/2004-09-22

I decided to install these RPMs to see if they help. The RPM
installation went just fine with no hiccups or dependency messages.
However, the problem described above still occurs when I start up X
server or boot into run-level 5. Only, this time, the display starts
up nice and clear as if the problem has been correct, but then it
slowly starts the lines and flickering and degrades again. It does not
appear to go blank now; it only has flickering lines running across it
and continually gets worse.

I've also changed the HorizSync and VertRefresh both to 60.0 to see if
that would affect it. It does not. I continue to see the same results.
Comment 8 Mike A. Harris 2004-10-12 18:49:09 EDT
Please upgrade to our official xorg-x11-6.8.1 rpm packages and see
if the problem persists.  I assume it will, but we need you to
test our own packages.  If you can still reproduce this with
the latest rawhide rpm packages, including xorg-x11 updates and
kernel updates, please file a new bug report in X.Org bugzilla
at http://bugs.freedesktop.org in the "xorg" component, which
will maximize the number of Radeon driver hackers aware of this
issue, including ATI.

Once you've filed the bug report at X.Org, please paste the URL
here, and we will track the issue in the X.Org bugzilla and
review any fixes that become available for inclusion in Fedora
Core 3.

Thanks in advance.
Comment 9 Mike A. Harris 2004-10-12 18:49:59 EDT
Oops, I accidentally marked my previous comment as "private".  Fixed.
Comment 11 Mike A. Harris 2004-10-12 18:52:40 EDT
Changing bug component to "xorg-x11" as we do not ship XFree86 in
FC2 or later.
Comment 12 Kevin E. Martin 2004-10-20 16:33:57 EDT
There have been a few monitor/flat panel detection issues resolved in
the more recent builds.  Please upgrade to the xorg-x11-6.8.1-12 or
newer build and let us know as soon as possible if the flickering
problems have been resolved.
Comment 13 Mike A. Harris 2004-10-20 20:22:37 EDT
xorg-x11-6.8.1-12 is now available for download via ftp,
and http at the following URLs:

    ftp://people.redhat.com/mharris/testing/unstable
    http://people.redhat.com/mharris/testing/unstable

Please test these packages, and update the report to indicate
if the SEGV is no longer reproduceable.
Comment 14 Ben Ramsey 2004-11-09 14:34:57 EST
Sorry for the lack of response. I had to use this machine as a Windows
machine for a while, but since the release of Fedora Core 3 yesterday,
I used Partition Magic to section off half of the drive to dedicate to
FC3, which I promptly installed. The install went fine, but the screen
is still having the same problems--and FC3 uses the 6.8.1-12 RPMs.

So, that didn't fix the problem.
Comment 15 Ben Ramsey 2004-11-11 10:57:24 EST
Finally got around to adding this as a bug at bugs.freedesktop.org:

http://freedesktop.org/bugzilla/show_bug.cgi?id=1829
Comment 16 Ben Ramsey 2004-11-15 09:51:26 EST
Just wanted to point out that, in the morning (or anytime I start up
the computer after it's been turned off for many hours), when I start
up the machine, I can use the Linux (FC3) partition for about 30
minutes with a nice, clear screen before the horizontal flickering
lines begin to appear. Shortly after they appear, though, the screen
begins to grow worse and worse with the lines until it's completely blank.

I thought it might be a hardware problem, but the screen is fine on
the Windows partition, so that makes me think it's a driver problem.
Nevertheless, I'm going to try this later today or tomorrow on a brand
new IBM R51 just to test the hardware theory.
Comment 17 Ben Ramsey 2004-11-19 11:35:20 EST
FYI, I was unable to get one of the R51s to test this on, however, I'm
not sure whether it would make much difference. The R51s we have use
the IBM ThinkPad 1024x768 LCD Panels, whereas the R40 I'm trying to
get this to work on uses an IBM ThinkPad 1400x1050 LCD Panel. Is the
xorg driver made to handle such a high resolution on laptops?
Comment 18 Ben Ramsey 2004-11-19 20:44:15 EST
I've not heard from anyone for a while on here, and Freedesktop.org
appears to be down because someone compromised their servers.
Anyway... I'm not sure whether I ever posted this, but my monitor is
the 15" Active Matrix XGA-TFT display (1400x1050). Most people who
have FC working on their IBM R40s are using the 15 or 14.1 inch
display, XGA (1024 x 768). I'm not sure whether it makes a difference.
Comment 19 Ben Ramsey 2004-12-02 12:01:19 EST
Created attachment 107775 [details]
X config file from /etc/X11/xorg.conf

Since I have installed FC3 and this bug was originally for FC3 test 1 or 2, I
have decided to upload the newest version of the xorg.conf file. I have not
touched this file or changed it in any way. What you see is the default config
as determined through the installation setup process.
Comment 20 Ben Ramsey 2004-12-02 12:02:28 EST
Created attachment 107776 [details]
X log file from /var/log/Xorg.*.log

Uploading this newest log file to update the bug since I installed FC3 over FC3
test 2.
Comment 21 Ben Ramsey 2004-12-03 00:33:45 EST
I went to
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/
and grabbed the updated xorg-x11 RPMs, updating my installed RPMs from
6.8.1-12 to 6.8.1-22. After running 'rpm -Uvh xorg-x11-*.rpm' to
upgrade/install all 18 RPMs, I rebooted the machine.

The same issue continues to occur when the machine boots into runlevel
5 (GUI).
Comment 22 Ben Ramsey 2005-01-11 12:58:08 EST
I know this isn't exactly a help forum, but I was wondering if anyone
is actually working on this or having any luck with it? I'm still
having this problem, and I'm having to use my Windows partition for
work. I'd love to be able to use Linux/Fedora again.

Thanks!
Comment 23 Mike A. Harris 2005-01-11 17:45:47 EST
Thanks for reporting this issue to X.Org developers via the
freedesktop.org bugzilla, as this will increase the likelyhood
of someone investigating this sooner and potentially fixing the
issue.  I've added myself on the CC of the upstream bug report
and we will track this issue in the X.Org bugzilla from now on.

Once a bug fix is available in X.Org CVS for this issue, we will
review it for consideration in future Fedora Core updates.

Setting bug status to "UPSTREAM" for tracking in the X.org bugzilla.

Note You need to log in before you can comment on or make changes to this bug.