Bug 1331473 - Minimize code duplication between glfs_resolve_component and gf_fill_iatt_for_dirent
Summary: Minimize code duplication between glfs_resolve_component and gf_fill_iatt_fo...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-28 15:04 UTC by Mohammed Rafi KC
Modified: 2018-08-29 03:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 03:53:13 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2016-04-28 15:04:44 UTC
Description of problem:

 gf_fill_iatt_for_dirent function does similar work as glfs_resolve_component. Therefore it would be wise to refactor these code to minimize code duplication and hence improve code maintainence. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Amar Tumballi 2018-08-29 03:53:13 UTC
Lot of time since no activity on this bug. We have either fixed it already or it is mostly not critical anymore!

Please re-open the bug if the issue is burning for you, or you want to take the bug to closure with fixes.


Note You need to log in before you can comment on or make changes to this bug.