Bug 1331496 - [Regression] Firefox 46.0-4 breaks H.264 support, missing ffmpeg-libs
Summary: [Regression] Firefox 46.0-4 breaks H.264 support, missing ffmpeg-libs
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-28 16:50 UTC by Christian Stadelmann
Modified: 2016-07-19 14:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-09 15:29:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Christian Stadelmann 2016-04-28 16:50:17 UTC
Version-Release number of selected component (if applicable):
firefox-46.0-4.fc24.x86_64

How reproducible:
always

Steps to Reproduce:
1. Create a new profile (just as a precaution to make sure no addons/preferences interfere)
2. load https://www.youtube.com/html5
3. watch output

Actual results:
H.264 is not supported

Expected results:
H.264 should be supported as it was in previous Firefox (45.x and earlier) releases.

Additional info:
This issue was not present in firefox-45.0.2-2.fc24.

Comment 1 Kamil Páral 2016-04-28 18:30:43 UTC
I can confirm this on my machine.

Comment 2 Martin Stransky 2016-04-29 09:03:45 UTC
Firefox moved from gstreamer to ffmpeg. Make sure you have installed ffmpeg-libs.

Comment 3 Christian Stadelmann 2016-04-29 09:57:40 UTC
(In reply to Martin Stransky from comment #2)
> Firefox moved from gstreamer to ffmpeg. Make sure you have installed
> ffmpeg-libs.

I don't have ffmpeg-libs installed and I can't install it since RPMFusion repositories are not ready for F24 yet. Between F23 and F24, libvpx (which ffmpeg depends on) got a soname version bump. F23 rpmfusion packages hence can't be installed on F24.

There is a firefox system plugin called "OpenH264". It should be enough to play H.264 videos. There is no need to use ffmpeg or gstreamer. Using this OpenH264 plugin worked fine on firefox 45.0.2 on the same machine, I think (not sure) even without gstreamer.

Comment 4 Martin Stransky 2016-04-29 12:52:01 UTC
OpenH264 is banned by Fedora, see https://fedorahosted.org/fesco/ticket/1359. If you want to use it you need to enable it, see https://fedoraproject.org/wiki/OpenH264

Comment 5 Christian Stadelmann 2016-04-29 16:42:24 UTC
Ok, that came quite unexpected. Is there any way to put this e.g. in the release notes? I guess I won't be the last person stumbling over this.

Comment 6 Piotr Drąg 2016-04-30 11:15:10 UTC
I do have OpenH264 enabled, and YouTube still shows red !s by H.264 and MSE & H.264 support. It did work in 45.

Comment 7 Christian Stadelmann 2016-04-30 17:45:31 UTC
(In reply to Piotr Drąg from comment #6)
> I do have OpenH264 enabled, and YouTube still shows red !s by H.264 and MSE
> & H.264 support. It did work in 45.

Same here.

Comment 8 Kamil Páral 2016-05-02 07:43:46 UTC
OpenH264 seems currently used only for WebRTC:
https://bugzilla.mozilla.org/show_bug.cgi?id=1057646

Comment 9 Martin Stransky 2016-05-02 11:21:42 UTC
Sorry, but I can't help you here. If you want to use H.264 you need to install ffmpeg-libs. There's no other way how to get H.264 working in Firefox 46 and later.

Comment 10 Martin Stransky 2016-05-02 11:23:01 UTC
We may need to update Release Notes for that. Kamil, co you do that or shall I step in?

Comment 11 Kamil Páral 2016-05-02 13:45:08 UTC
I'll add it to CommonBugs. Putting it into Release Notes is a good idea as well, we should probably do both, but I have no idea what the correct process is. Usually it's just about pinging someone from the documentation team, I believe. If you could that, that would be great.

Comment 12 Kamil Páral 2016-05-04 08:05:47 UTC
Martin, please note you could also add it to the Beta release announcement [1], and to the Final release announcement when its time comes.

[1] https://linuxmodder.wordpress.com/2016/05/03/f24-beta-announcement-technical-end-user-input-sought/

Comment 13 Christian Stadelmann 2016-05-08 16:39:16 UTC
For anybody interested, a recent update to fedora-repos package added a new repository to fedora for mozilla/cisco openh264 code implementation. It is disabled by default and also available on https://codecs.fedoraproject.org/openh264/.

This information should probably go into Fedora 24 release notes or "Common bugs"[1] too. I'm reopening this bug report until this is done.

[1] https://fedoraproject.org/wiki/Common_F24_bugs

Comment 14 Martin Stransky 2016-05-09 09:15:16 UTC
(In reply to Christian Stadelmann from comment #13)
> For anybody interested, a recent update to fedora-repos package added a new
> repository to fedora for mozilla/cisco openh264 code implementation. It is
> disabled by default and also available on
> https://codecs.fedoraproject.org/openh264/.
> 
> This information should probably go into Fedora 24 release notes or "Common
> bugs"[1] too. I'm reopening this bug report until this is done.
> 
> [1] https://fedoraproject.org/wiki/Common_F24_bugs

Are you sure the openh264 really fixed h264 playback on youtube? Because it does not work for me and only ffmpeg-libs provides the h264 playback for now.

Comment 15 Christian Stadelmann 2016-05-09 09:24:40 UTC
(In reply to Martin Stransky from comment #14)
> Are you sure the openh264 really fixed h264 playback on youtube? Because it
> does not work for me and only ffmpeg-libs provides the h264 playback for now.

No, it didn't fix H264 playback on youtube. Am I mixing up stuff (openh264 for webrtc vs. H264 for video playback) again? If yes, sorry for the noise. I'd expected this openh264 plugin for gstreamer to add h264 playback to any application using gstreamer, including firefox.

Comment 16 Martin Stransky 2016-05-09 09:30:06 UTC
(In reply to Christian Stadelmann from comment #15)
> (In reply to Martin Stransky from comment #14)
> > Are you sure the openh264 really fixed h264 playback on youtube? Because it
> > does not work for me and only ffmpeg-libs provides the h264 playback for now.
> 
> No, it didn't fix H264 playback on youtube. Am I mixing up stuff (openh264
> for webrtc vs. H264 for video playback) again? If yes, sorry for the noise.
> I'd expected this openh264 plugin for gstreamer to add h264 playback to any
> application using gstreamer, including firefox.

Unfortunately gstreamer was replaced by ffmpeg in Firefox so it's the reason Firefox requires ffmpeg-libs to play h264 now.

Comment 17 Christian Stadelmann 2016-05-09 15:29:45 UTC
(In reply to Martin Stransky from comment #16)
> 
> Unfortunately gstreamer was replaced by ffmpeg in Firefox so it's the reason
> Firefox requires ffmpeg-libs to play h264 now.

Ok, thanks for clarification.

Closing again since the other stuff has been published in "Common F24 bugs"[1].

[1] https://fedoraproject.org/wiki/Common_F24_bugs#firefox-ffmpeg


Note You need to log in before you can comment on or make changes to this bug.