Bug 133161 - rpm database corruption
Summary: rpm database corruption
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-21 23:42 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-23 16:22:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2004-09-21 23:42:29 UTC
Description of problem:
During a yum update one of the i586 (VIA EPIA) boxes had rpm explode
with a message about running some kind of db4 rescue tool (the message
was mostly mangled because whatever blew up also emitted characters
that trashed the terminal font)

Doing an rpm --rebuild fixed it and repeating the update worked fine. 

I have saved the rpm database directory after the crash before the
rebuild in case it helps with any debugging if this bug report is useful.

How reproducible:
Not reproducible


Additional info:

Comment 1 Jeff Johnson 2004-09-22 11:26:15 UTC
A url to the rpdm tar ball please, and I will look.
Post mortem's are usually uninformative, I need a
reproducer to attempt a fix.

Comment 2 Jeff Johnson 2004-09-22 11:28:20 UTC
rpmdb tar ball.

Any data loss? is the other interesting question. A --rebuilddb
checks header digests, and will discard any headers that fail.



Comment 3 Alan Cox 2004-10-22 12:40:44 UTC
Sorry got occupied in other stuff. No sign of data loss, will attach
tar ball now


Comment 4 Alan Cox 2004-10-22 13:06:10 UTC
Ok it wont let me , uploading to rpmdb.tar.gz in my Red Hat home dir..


Comment 5 Jeff Johnson 2004-10-22 19:58:40 UTC
OK, but post mortem rpmdb is hard decipher.

Can you reproduce this on demand, or at least statistical
chance of catching before disks fill up? If so, I can can get
you a version of rpm that enables db logs for display with
db*_printlog.

Without seeing the time dimension of rpmdb activity, I do not believe
I have a prayer of diagnosing DB_PAGE_NOTFOUND problems in finite time.

Comment 6 Alan Cox 2004-10-22 21:05:59 UTC
Not reproducable at all, feel free to close this sorry it didnt help



Note You need to log in before you can comment on or make changes to this bug.