Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 133161 - rpm database corruption
rpm database corruption
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-21 19:42 EDT by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-23 12:22:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-09-21 19:42:29 EDT
Description of problem:
During a yum update one of the i586 (VIA EPIA) boxes had rpm explode
with a message about running some kind of db4 rescue tool (the message
was mostly mangled because whatever blew up also emitted characters
that trashed the terminal font)

Doing an rpm --rebuild fixed it and repeating the update worked fine. 

I have saved the rpm database directory after the crash before the
rebuild in case it helps with any debugging if this bug report is useful.

How reproducible:
Not reproducible


Additional info:
Comment 1 Jeff Johnson 2004-09-22 07:26:15 EDT
A url to the rpdm tar ball please, and I will look.
Post mortem's are usually uninformative, I need a
reproducer to attempt a fix.
Comment 2 Jeff Johnson 2004-09-22 07:28:20 EDT
rpmdb tar ball.

Any data loss? is the other interesting question. A --rebuilddb
checks header digests, and will discard any headers that fail.

Comment 3 Alan Cox 2004-10-22 08:40:44 EDT
Sorry got occupied in other stuff. No sign of data loss, will attach
tar ball now
Comment 4 Alan Cox 2004-10-22 09:06:10 EDT
Ok it wont let me , uploading to rpmdb.tar.gz in my Red Hat home dir..
Comment 5 Jeff Johnson 2004-10-22 15:58:40 EDT
OK, but post mortem rpmdb is hard decipher.

Can you reproduce this on demand, or at least statistical
chance of catching before disks fill up? If so, I can can get
you a version of rpm that enables db logs for display with
db*_printlog.

Without seeing the time dimension of rpmdb activity, I do not believe
I have a prayer of diagnosing DB_PAGE_NOTFOUND problems in finite time.
Comment 6 Alan Cox 2004-10-22 17:05:59 EDT
Not reproducable at all, feel free to close this sorry it didnt help

Note You need to log in before you can comment on or make changes to this bug.