Bug 1331622 - Failed to add rhev-h ng 4.0 to rhev-m 3.6
Summary: Failed to add rhev-h ng 4.0 to rhev-m 3.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-release-rhev-hypervisor
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: Fabian Deutsch
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-29 04:05 UTC by Huijuan Zhao
Modified: 2016-08-23 21:11 UTC (History)
11 users (show)

Fixed In Version: rhev-hypervisor7-ng-3.6-20160429.0.x86_64
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:11:48 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
screenshot of add rhevh ng 4.0 to rhevm 3.6 failed (126.33 KB, image/png)
2016-04-29 04:07 UTC, Huijuan Zhao
no flags Details
The log on rhev-h ng (5.88 MB, application/x-gzip)
2016-04-29 04:08 UTC, Huijuan Zhao
no flags Details
The log on rhevm 3.6: /var/log/ovirt-engine/host-deploy/ovirt-host-deploy-* (228.99 KB, text/plain)
2016-04-29 04:12 UTC, Huijuan Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1688 normal SHIPPED_LIVE redhat-release-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:37:04 UTC

Description Huijuan Zhao 2016-04-29 04:05:26 UTC
Description of problem:
Failed to add rhevh ng 4.0 to rhevm 3.6

Version-Release number of selected component (if applicable):
rhev-hypervisor7-ng-3.6-20160426.0.x86_64
imgbased-0.6-0.1.el7ev.noarch
vdsm-4.17.27-0.el7ev.noarch

Red Hat Enterprise Virtualization Manager Version: 3.6.6-0.1.el6


How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-ng-3.6-20160426.0.x86_64
2. Login rhevh, setup vdsm workaround:
   vdsm-tool configure --force
   systemctl start vdsmd
3. Add rhevh ng 4.0 to rhevm 3.6 on rhevm side

Actual results:
1. After step3, failed to add rhevh ng 4.0 to rhevm 3.6

Expected results:
1. After step3, should add rhevh ng 4.0 to rhevm 3.6 successful

Additional info:

Comment 1 Huijuan Zhao 2016-04-29 04:07:20 UTC
Created attachment 1152110 [details]
screenshot of add rhevh ng 4.0 to rhevm 3.6 failed

Comment 2 Huijuan Zhao 2016-04-29 04:08:40 UTC
Created attachment 1152111 [details]
The log on rhev-h ng

Comment 3 Douglas Schilling Landgraf 2016-04-29 04:11:25 UTC
I have reproduced this report and host-deploy shows:

method exception
Traceback (most recent call last):
  File "/tmp/ovirt-YtLPlDUvTW/pythonlib/otopi/context.py", line 146,
in _executeMethod
    method['method']()
  File "/tmp/ovirt-YtLPlDUvTW/otopi-plugins/ovirt-host-deploy/vdsm/software.py",
line 83, in _validation
    version=ver,
RuntimeError: Distribution redhat version 3.6 is not supported

Comment 4 Huijuan Zhao 2016-04-29 04:12:49 UTC
Created attachment 1152112 [details]
The log on rhevm 3.6: /var/log/ovirt-engine/host-deploy/ovirt-host-deploy-*

Comment 5 Douglas Schilling Landgraf 2016-04-29 04:14:14 UTC
ovirt-host-deploy compare the minimum supported platform (redhat) and
version (6.2) against
platform.linux_distribution(full_distribution_name=0)[:2]. This python
call reads /etc/redhat-release instead of /etc/os-release and doesn't
match as the version field is (3.6).

investigation from:
strace -o output -s255 -f python -c "import
platform;print(platform.linux_distribution(full_distribution_name=0)[:2])"

Comment 11 Huijuan Zhao 2016-05-03 07:00:51 UTC
According to comment10, I tested on the latest rhevh ngn build, the result is pass.
 
Version-Release number of selected component (if applicable):
rhev-hypervisor7-ng-3.6-20160429.0.x86_64
imgbased-0.6-0.1.el7ev.noarch
vdsm-4.17.27-0.el7ev.noarch
Red Hat Enterprise Virtualization Manager Version: 3.6.6-0.1.el6

Test steps:
1. Install rhev-hypervisor7-ng-3.6-20160429.0.x86_64
2. Login rhevh, setup vdsm workaround:
   vdsm-tool configure --force
   systemctl start vdsmd
3. Add rhevh ng 4.0 to rhevm 3.6 on rhevm side

Test results:
1. After step3, add rhevh ng 4.0 to rhevm 3.6 successful

So this bug is fixed on rhev-hypervisor7-ng-3.6-20160429.0.x86_64, I will change the status to VERIFIED.

Comment 13 errata-xmlrpc 2016-08-23 21:11:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1688.html


Note You need to log in before you can comment on or make changes to this bug.