Bug 1331630 - Anaconda crashed during installation
Summary: Anaconda crashed during installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1332326 (view as bug list)
Depends On:
Blocks: F24BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-04-29 06:13 UTC by Petr Schindler
Modified: 2016-05-07 09:24 UTC (History)
10 users (show)

Fixed In Version: python-blivet-1.20.1-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-07 09:24:49 UTC
Type: Bug


Attachments (Terms of Use)
journal ctl with coredump (161.24 KB, text/plain)
2016-04-29 06:13 UTC, Petr Schindler
no flags Details
journal after boot (246.46 KB, text/plain)
2016-04-29 06:17 UTC, Petr Schindler
no flags Details
anaconda.log (102.82 KB, text/plain)
2016-04-29 06:18 UTC, Petr Schindler
no flags Details
/tmp/lvm.log (9.42 MB, text/plain)
2016-04-29 06:19 UTC, Petr Schindler
no flags Details
program.log (196.83 KB, text/plain)
2016-04-29 06:20 UTC, Petr Schindler
no flags Details
storage.log (359.15 KB, text/plain)
2016-04-29 06:21 UTC, Petr Schindler
no flags Details
output of lsblk (2.10 KB, text/plain)
2016-04-29 06:39 UTC, Petr Schindler
no flags Details
/tmp from another reproducer (5.62 MB, application/x-tar)
2016-04-29 07:46 UTC, Petr Schindler
no flags Details

Description Petr Schindler 2016-04-29 06:13:14 UTC
Created attachment 1152130 [details]
journal ctl with coredump

Description of problem:
I tried to install from Server dvd Beta 1.2 on the computer with (your favourite) Firmware RAID. During boot I noticed that there was some message from systemd about RAID which can be important (the whole log will be attached as journal-boot.log:
Apr 29 05:46:08 localhost systemd[1]: Failed to start Software RAID monitoring and management.
I followed all the defaults. I only selected the RAID(5) for the installation and chose to delete all the disk.
After the installation started I went to root password spoke, insert the password and after I clicked on done the anaconda crashed.

It crashed totally I could see only black window. On the tty2 I could see:
File "/usr/lib/python3.5/site-packages/blivet/formats/__init__.py", line 426 in destroy
File "/usr/lib/python3.5/site-packages/blivet/formats/lvmpv.py", line 131 in _destroy
(those to lines filled the whole window)
And on the bottom:
Thread (0x00007f50e2e15700 (most recent call first):
  File "/usr/lib/python3.5/site-packages/pyanaconda/ui/gui/__init__.py", line 873 in run
  File "/sbin/anaconda", line 1196 in <module>

Pane is dead

You can find the core dump in anaconda_crash.log there is also lot of messages from lvmdbusd above the dump.


Version-Release number of selected component (if applicable):
anaconda 24.13.4-1

How reproducible:
Happened once so far (but I tried to run new compose beta 1.2 just once)

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Petr Schindler 2016-04-29 06:17:33 UTC
Created attachment 1152131 [details]
journal after boot

Comment 2 Petr Schindler 2016-04-29 06:18:15 UTC
Created attachment 1152132 [details]
anaconda.log

Comment 3 Petr Schindler 2016-04-29 06:19:56 UTC
Created attachment 1152134 [details]
/tmp/lvm.log

Comment 4 Petr Schindler 2016-04-29 06:20:31 UTC
Created attachment 1152135 [details]
program.log

Comment 5 Petr Schindler 2016-04-29 06:21:01 UTC
Created attachment 1152138 [details]
storage.log

Comment 6 Petr Schindler 2016-04-29 06:39:41 UTC
Created attachment 1152142 [details]
output of lsblk

Comment 7 Petr Schindler 2016-04-29 07:12:03 UTC
I tried to run it again and it seems that I have computer in state when it happens in every attempt to install. The system which is installed on the computer is normally bootable. 

P. S.: Brno anaconda crew - You can come and look at it at any time, I'll leave it in this state for investigation.

Comment 8 Petr Schindler 2016-04-29 07:46:23 UTC
Created attachment 1152155 [details]
/tmp from another reproducer

Comment 9 Vratislav Podzimek 2016-04-29 08:28:14 UTC
https://github.com/rhinstaller/blivet/pull/397

Comment 10 Petr Schindler 2016-05-03 07:59:50 UTC
*** Bug 1332326 has been marked as a duplicate of this bug. ***

Comment 11 Petr Schindler 2016-05-03 08:04:04 UTC
Blocker proposal is in bug 1332326 comment 4

Comment 12 Kevin Fenzi 2016-05-03 19:35:39 UTC
Sadly does look like a blocker. +1

Comment 13 Dennis Gilmore 2016-05-03 19:57:58 UTC
+1 blocker

Comment 14 Fedora Update System 2016-05-03 20:03:02 UTC
python-blivet-1.20.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8cbf5a7cf8

Comment 15 Fedora Update System 2016-05-04 14:29:21 UTC
python-blivet-1.20.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8cbf5a7cf8

Comment 16 Adam Williamson 2016-05-05 03:19:46 UTC
I verified the fix for *this* in 1.6 (but unfortunately the same path hits other bugs later).

Comment 17 Kamil Páral 2016-05-06 11:00:18 UTC
Discussed at a go/no-go meeting [1]. Voted as AcceptedBlocker (Beta) - this was another crasher in the case of installing over LVM-on-RAID, but it does not seem to have a workaround besides manually destroying the existing layout, so we consider it to be significant enough to constitute a criteria violation for Beta as you cannot complete the install

[1] https://meetbot.fedoraproject.org/fedora-meeting-1/2016-05-05/f24-beta-go_no_go-meeting.2016-05-05-17.30.html

Comment 18 Fedora Update System 2016-05-07 09:24:44 UTC
python-blivet-1.20.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.