Bug 1331633 - "--spice-disable-auto-usbredir" should not be placed in group "--show-DIALOG-WINDOW"
Summary: "--spice-disable-auto-usbredir" should not be placed in group "--show-DIALOG-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.3
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-29 06:46 UTC by Xiaodai Wang
Modified: 2016-11-04 02:02 UTC (History)
5 users (show)

Fixed In Version: virt-manager-1.4.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 02:02:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2269 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2016-11-03 13:34:19 UTC

Description Xiaodai Wang 2016-04-29 06:46:02 UTC
Description of problem:
"--spice-disable-auto-usbredir" should not be placed in group "--show-DIALOG-WINDOW"

Version-Release number of selected component (if applicable):
virt-manager-1.3.2-1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run "man virt-manager".
2. Check the "--show-DIALOG-WINDOW" part.

       --show-DIALOG-WINDOW
           Display the corresponding "DIALOG-WINDOW" when launching "virt-manager". This function implies --no-conn-autostart and the manager window will not be shown at startup in this case.

           The following "DIALOG-WINDOW" options are currently available:

           --show-domain-creator
               Display the wizard for creating new virtual machines

           --show-domain-editor NAME|ID|UUID
               Display the dialog for editing properties of the virtual machine with unique ID matching either the domain name, ID, or UUID

           --show-domain-performance NAME|ID|UUID
               Display the dialog for monitoring performance of the virtual machine with unique ID matching either the domain name, ID, or UUID

           --show-domain-console NAME|ID|UUID
               Display the virtual console of the virtual machine with unique ID matching either the domain name, ID, or UUID

           --show-host-summary
               Display the main window summarizing performance for all virtual machines on the host.

           --spice-disable-auto-usbredir
               Auto USB redirection is supported by default. This option switches off it.


Actual results:
"--spice-disable-auto-usbredir" is listed in the "--show-DIALOG-WINDOW" part with other --show-* parts.

Expected results:
"--spice-disable-auto-usbredir" should not be listed in "--show-DIALOG-WINDOW" part.

Additional info:

Comment 2 Pavel Hrdina 2016-05-20 13:34:43 UTC
Upstream commit:

commit 21e29a417808ccc40b6c60b7ebcccb2843396c4d
Author: Pavel Hrdina <phrdina>
Date:   Fri May 20 15:30:57 2016 +0200

    man: virt-manager: properly indent --spice-disable-auto-usbredir

Comment 4 XiaoyunHu 2016-06-23 03:18:23 UTC
I can reproduce this bug with package:
virt-manager-1.3.2-1.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.4.0-1.el7.noarch

Steps:
1. Run "man virt-manager"
2. Chect if " – spice-disable-auto-usbredir " is listed in " – show-DIALOG-WINDOW " part.

Results:
After step2, " – spice-disable-auto-usbredir " is not listed in " – show-DIALOG-WINDOW " part.

According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.

Comment 6 errata-xmlrpc 2016-11-04 02:02:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html


Note You need to log in before you can comment on or make changes to this bug.