Bug 1331658 - [geo-rep]: schedule_georep.py doesn't work when invoked using cron
Summary: [geo-rep]: schedule_georep.py doesn't work when invoked using cron
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1331376
Blocks: 1331924
TreeView+ depends on / blocked
 
Reported: 2016-04-29 07:35 UTC by Aravinda VK
Modified: 2016-06-16 14:04 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1331376
: 1331924 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:04:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-04-29 07:35:19 UTC
+++ This bug was initially created as a clone of Bug #1331376 +++

Description of problem:
=======================

When ran the schedule_georep.py using cron, it failed with the following traceback:

Traceback (most recent call last):
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 470, in <module>
    main(args)
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 362, in main
    execute(cmd)
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 86, in execute
    p = subprocess.Popen(cmd, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Traceback (most recent call last):
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 470, in <module>
    main(args)
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 362, in main
    execute(cmd)
  File "/usr/share/glusterfs/scripts/schedule_georep.py", line 86, in execute
    p = subprocess.Popen(cmd, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory



Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.7.9-2.el7rhgs.x86_64


How reproducible:
=================

1/1

Comment 1 Vijay Bellur 2016-04-29 08:03:35 UTC
REVIEW: http://review.gluster.org/14111 (geo-rep: Fix gluster binary invocation while running as cron) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Vijay Bellur 2016-04-29 09:28:36 UTC
REVIEW: http://review.gluster.org/14111 (geo-rep: Fix gluster binary invocation while running as cron) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Vijay Bellur 2016-04-29 14:11:22 UTC
REVIEW: http://review.gluster.org/14111 (geo-rep: Fix gluster binary invocation while running as cron) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 4 Vijay Bellur 2016-04-30 04:14:03 UTC
COMMIT: http://review.gluster.org/14111 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 80e3832ec16f69d4184172cfc9afa9e42533e0ef
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Apr 29 13:03:40 2016 +0530

    geo-rep: Fix gluster binary invocation while running as cron
    
    When scheduler script was executed as cron, it was unable to detect
    the Gluster binaries.
    
    BUG: 1331658
    Change-Id: Ic9c533586ed9a472765f69aa2f87d004c46d4340
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/14111
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Niels de Vos 2016-06-16 14:04:45 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.